Bug 1319645 - setting enable-shared-storage without mentioning the domain, doesn't enables shared storage
Summary: setting enable-shared-storage without mentioning the domain, doesn't enables ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: 3.7.0
Hardware: x86_64
OS: All
unspecified
high
Target Milestone: ---
Assignee: Gaurav Kumar Garg
QA Contact:
URL:
Whiteboard:
Depends On: 1238224
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-21 09:13 UTC by Gaurav Kumar Garg
Modified: 2016-04-19 07:00 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.7.10
Doc Type: Bug Fix
Doc Text:
Clone Of: 1238224
Environment:
Last Closed: 2016-04-19 07:00:16 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Gaurav Kumar Garg 2016-03-21 09:13:11 UTC
+++ This bug was initially created as a clone of Bug #1238224 +++

+++ This bug was initially created as a clone of Bug #1236153 +++

Description of problem:
-----------------------
Setting the option, enable-shared-storage, without mentioning the domain 'cluster' doesn't creates the gluster_shared_storage volume

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
glusterfs-3.7.1-5.el6rhs

How reproducible:
------------------
Always

Steps to Reproduce:
--------------------
1. Create a volume of any type
2. Enable enable-shared-storage on the volume, without mentioning the domain
(i.e) gluster volume set all enable-shared-storage enable

Actual results:
---------------
Setting enabling the option enable-shared-storage doesn't created the shared gluster volume by name gluster_shared_storage

Expected results:
-----------------
gluster_shared_storage should be created when enable-shared-storage is enabled

Additional info:
----------------
RCA is here.
The hook script '/var/lib/glusterd/hooks/1/set/post/S32gluster_enable_shared_storage.sh' checks for the key 'cluster.enable-shared-storage' and exits when the key is 'enable-shared-storage'

<snip_from_hook_script>
if [ "$key" != "cluster.enable-shared-storage" ]; then
    exit;
fi
</snip_from_hook_script>

--- Additional comment from Anand Avati on 2015-07-01 08:31:07 EDT ---

REVIEW: http://review.gluster.org/11491 (extra: "enable-shared-storage" key should create shared-storage) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Anand Avati on 2015-07-13 06:26:02 EDT ---

COMMIT: http://review.gluster.org/11491 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 890e58f5d4d3db9477e36cac3d16798ffe3b0480
Author: Gaurav Kumar Garg <ggarg@redhat.com>
Date:   Wed Jul 1 17:55:47 2015 +0530

    extra: "enable-shared-storage" key should create shared-storage
    
    Currently while creating shared storage it accept only
    "cluster.enable-shared-storage" key. It should also
    accept "enable-shared-storage" key.
    
    Change-Id: I4c68782f4b7927ec8cd725e411b0b9db17d9c48d
    BUG: 1238224
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/11491
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>

Comment 1 Vijay Bellur 2016-03-21 09:15:10 UTC
REVIEW: http://review.gluster.org/13794 (extra: "enable-shared-storage" key should create shared-storage) posted (#1) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 2 Vijay Bellur 2016-03-22 04:04:29 UTC
COMMIT: http://review.gluster.org/13794 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 8b3dd6a7841755816ac15cb206602efb07c3c102
Author: Gaurav Kumar Garg <ggarg@redhat.com>
Date:   Wed Jul 1 17:55:47 2015 +0530

    extra: "enable-shared-storage" key should create shared-storage
    
    This patch is backport of: http://review.gluster.org/#/c/11491/
    
    Currently while creating shared storage it accept only
    "cluster.enable-shared-storage" key. It should also
    accept "enable-shared-storage" key.
    
    
    Change-Id: I4c68782f4b7927ec8cd725e411b0b9db17d9c48d
    BUG: 1319645
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    
      >> Change-Id: I4c68782f4b7927ec8cd725e411b0b9db17d9c48d
      >> BUG: 1238224
      >> Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
      >> Reviewed-on: http://review.gluster.org/11491
      >> Tested-by: NetBSD Build System <jenkins@build.gluster.org>
      >> Tested-by: Gluster Build System <jenkins@build.gluster.com>
      >> Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
      >> Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    (cherry picked from commit 890e58f5d4d3db9477e36cac3d16798ffe3b0480)
    
    Change-Id: Ic77fd67b90be3381cff33f18f49eee97972eb19a
    Reviewed-on: http://review.gluster.org/13794
    Tested-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 3 Kaushal 2016-04-19 07:00:16 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.10, please open a new bug report.

glusterfs-3.7.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026164.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.