Bug 1319721 - Call to getImagesList on NFS on host without connected storage pool but with SD, return {'status': {'message': 'OK', 'code': 0}, 'imageslist': []} also when we have images
Summary: Call to getImagesList on NFS on host without connected storage pool but with ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-ha
Classification: oVirt
Component: General
Version: 1.3.5
Hardware: x86_64
OS: Linux
urgent
urgent vote
Target Milestone: ovirt-3.6.4
: 1.3.5.1
Assignee: Simone Tiraboschi
QA Contact: Artyom
URL:
Whiteboard:
Depends On:
Blocks: 1306825 1317901
TreeView+ depends on / blocked
 
Reported: 2016-03-21 11:44 UTC by Artyom
Modified: 2016-04-05 13:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1320112 (view as bug list)
Environment:
Last Closed: 2016-04-05 13:54:49 UTC
oVirt Team: Integration
rule-engine: ovirt-3.6.z+
rule-engine: blocker+
ylavi: planning_ack+
sbonazzo: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
VDSM logs (28.94 KB, text/plain)
2016-03-21 13:03 UTC, Simone Tiraboschi
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1306825 0 urgent CLOSED hosted-engine upgrade fails after upgrade hosts from el6 to el7 2021-02-22 00:41:40 UTC
oVirt gerrit 54982 0 master MERGED storage: improved workaround for getImagesList on NFS 2016-03-21 14:30:18 UTC
oVirt gerrit 55001 0 ovirt-hosted-engine-ha-1.3 MERGED storage: improved workaround for getImagesList on NFS 2016-03-21 14:36:35 UTC

Internal Links: 1306825

Description Artyom 2016-03-21 11:44:41 UTC
Description of problem:
Call to getImagesList on host without connected storage pool, but with SD, return {'status': {'message': 'OK', 'code': 0}

Version-Release number of selected component (if applicable):
vdsm-4.17.23.1-0.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. run script
sdUUID = 'SD_UUID'
 cli = vdscli.connect(timeout=60)
 result = cli.getImagesList(sdUUID)
 print(result)
 result = cli.getConnectedStoragePoolsList()
 print(result)
2.
3.

Actual results:
That prints:
 {'status': {'message': 'OK', 'code': 0}, 'imageslist': []}
 {'status': {'message': 'OK', 'code': 0}, 'poollist': []}

Expected results:
result = cli.getImagesList(sdUUID)
print(result)
{'status': {'message': 'list index out of range', 'code': 100}}

Additional info:
the image are available on the NFS share 

[root@alma07 images]# pwd
/rhev/data-center/mnt/10.35.64.11:_vol_RHEV_Virt_alukiano__HE__upgrade/3ac831d6-6124-4b42-a060-f89c64be09a1/images
[root@alma07 images]# ls -l
total 16
drwxr-xr-x. 2 vdsm kvm 4096 17 mar 15.36 4d1915e1-a9f7-4bca-b666-0997adec5ef4
drwxr-xr-x. 2 vdsm kvm 4096 18 mar 00.52 995171f0-1abb-488b-9b18-3e17aad0c3de
drwxr-xr-x. 2 vdsm kvm 4096 20 mar 15.40 9ecd4e5f-bb24-4fd6-8c20-c442425b59b6
drwxr-xr-x. 2 vdsm kvm 4096 18 mar 00.52 b6b637a4-37be-48e9-aacb-e3d4a6be29cc

but VDSM is not reporting them.

Comment 1 Red Hat Bugzilla Rules Engine 2016-03-21 12:12:27 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Simone Tiraboschi 2016-03-21 13:03:40 UTC
Created attachment 1138586 [details]
VDSM logs

Comment 3 Allon Mureinik 2016-03-21 13:05:34 UTC
I don't understand. Isn't this just a duplicate of bug 1274622 ?

Comment 4 Simone Tiraboschi 2016-03-21 13:11:12 UTC
We can have an additional simple workaround on hosted-engine side (as for https://gerrit.ovirt.org/#/c/54982/ ) but, if possible, I'd prefer to get this properly fixed on VDSM side to prevent any other surprise on other behavior changes.

Comment 5 Simone Tiraboschi 2016-03-21 13:17:04 UTC
(In reply to Allon Mureinik from comment #3)
> I don't understand. Isn't this just a duplicate of bug 1274622 ?

No, unfortunately it's not: at 1274622 that call was failing with:
 {'status': {'message': 'list index out of range', 'code': 100}}
and we implemented a workaround for that directly globing under /rhev/data-center/mnt/{mnt_point}/{sduuid}/images to directly find the images on the NFS share.

Now it's also worst since VDSM returns 
 {'status': {'message': 'OK', 'code': 0}, 'imageslist': []} (which is wrong since the images are there!) and so our workaround doesn't trigger anymore.
We can add an additional workaround over that but if possible I'd prefer to get it properly fixed.

Comment 6 Sandro Bonazzola 2016-03-21 13:23:08 UTC
Workaround has been posted here: https://gerrit.ovirt.org/#/c/54982/1

Comment 7 Sandro Bonazzola 2016-03-21 13:31:24 UTC
Moving this bug to ovirt-hosted-engine-ha since it has been decided to use the workaround instead of a proper fix in vdsm. Allon, please consider to schedule a proper fix for 3.6.5.

Comment 8 Allon Mureinik 2016-03-21 15:25:59 UTC
(In reply to Sandro Bonazzola from comment #7)
> Moving this bug to ovirt-hosted-engine-ha since it has been decided to use
> the workaround instead of a proper fix in vdsm. Allon, please consider to
> schedule a proper fix for 3.6.5.
Please clone it to track that initiative, although, atm, I can't commit to such a fix.

Comment 9 Artyom 2016-03-23 09:54:13 UTC
Verified on ovirt-hosted-engine-ha-1.3.5.1-1.el7ev.noarch
See verification of bug https://bugzilla.redhat.com/show_bug.cgi?id=1306825


Note You need to log in before you can comment on or make changes to this bug.