Bug 1319766 - No validation for compute resource description length
Summary: No validation for compute resource description length
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources
Version: 6.2.0
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Adam Ruzicka
QA Contact: Lukas Pramuk
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-21 13:24 UTC by Oleksandr Shtaier
Modified: 2019-09-26 14:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:28:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot with issue for UI (36.42 KB, image/png)
2016-03-21 13:27 UTC, Oleksandr Shtaier
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 14326 None None None 2016-04-22 14:54:25 UTC

Description Oleksandr Shtaier 2016-03-21 13:24:24 UTC
Description of problem:
You can use description of any length for compute resource. The fact that all columns in WebUI start to collapse and entire style of web application for that page is ruined make that issue is more severe than similar issues

Version-Release number of selected component (if applicable):
6.2 SNAP4

How reproducible:
Always

Steps to Reproduce:
1. Try to create new compute resource with a very long (more than 1000 symbols) description

Actual results:
Entity is created and WebUI transformed in a bad manner

Expected results:
`is too long (maximum is 255 characters)` message is displayed as it was before

Additional info:

Comment 1 Oleksandr Shtaier 2016-03-21 13:27:59 UTC
Created attachment 1138603 [details]
Screenshot with issue for UI

Comment 4 Adam Ruzicka 2016-03-23 09:17:27 UTC
Created redmine issue http://projects.theforeman.org/issues/14326 from this bug

Comment 5 Bryan Kearney 2016-03-23 13:21:05 UTC
Upstream bug assigned to aruzicka@redhat.com

Comment 6 Bryan Kearney 2016-03-30 10:02:07 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14326 has been closed
-------------
Adam Ruzicka
Applied in changeset commit:f8b3dbe25ea80df3a41bc9f0353a7b8089dea2a3.

Comment 7 Lukas Pramuk 2016-04-06 15:50:09 UTC
VERIFIED.

@Sat6.2.0-Beta-Snap6.2

Compute Resource Description is ellipsized not to break page layout.
(page rendered w/o horizontal scrollbar )

Comment 9 errata-xmlrpc 2016-07-27 09:28:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.