Bug 131977 - 'bashbug' command referred to but not present
'bashbug' command referred to but not present
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-07 12:45 EDT by Zack Cerza
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 11:45:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2004-09-07 12:45:25 EDT
Description of problem:
In the bash man and info pages, and in bash's --help output, it is
mentioned that bugs should be reported via a command called 'bashbug',
but the command doesn't actually exist in the bash package.

Version-Release number of selected component (if applicable):
bash-3.0-9

Additional info:
Running 'locate bashbug' on a recent full rawhide install reveals the
following files:

/usr/share/man/fr/man1/bashbug.1.gz/usr/share/man/ja/man1/bashbug.1.gz
(man-pages-ja-20040815-1)
/usr/share/man/fr/man1/bashbug.1.gz (man-pages-fr-0.9.7-10)

If the bashbug utility won't be returning to the bash package, those
packages should probably have bugs filed on them.
Comment 1 Zack Cerza 2004-09-07 12:46:50 EDT
Uh, the 'following files' are really:

/usr/share/man/ja/man1/bashbug.1.gz (man-pages-ja-20040815-1)
/usr/share/man/fr/man1/bashbug.1.gz (man-pages-fr-0.9.7-10)
Comment 2 Tim Waugh 2004-09-07 12:53:07 EDT
It's removed for multilib.
Comment 3 Tim Waugh 2004-09-07 13:15:15 EDT
Building fixed bash package now.
Comment 4 Zack Cerza 2004-10-05 11:28:37 EDT
OK, I have a bashbug-64 now. Not sure why it's called that, since it's
a shell script, but hey.

bashbug-64 spawns xemacs when run in X. Looking in the script, it
tries 4 flavors of emacs before anything else that will normally
exist. Personally I'm a vim user (not to start a flamewar, emacs
genuinely confuses me), but maybe we could make, say, nano the
default? Not everyone knows how to use either emacs or vi, but nano is
a really easy-to-use editor.
Comment 5 Tim Waugh 2004-10-05 11:45:03 EDT
It's easy for someone who doesn't like emacs to just use:

 EDITOR=vim bashbug
Comment 6 Zack Cerza 2004-10-05 11:51:09 EDT
Ah, you're right. I should be exporting that anyway. Thanks :)

Note You need to log in before you can comment on or make changes to this bug.