Bug 1319791 - Cannot access docker compute resource via compute profile.
Summary: Cannot access docker compute resource via compute profile.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Container Management
Version: 6.2.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: Unspecified
Assignee: Daniel Lobato Garcia
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-21 14:24 UTC by Oleksandr Shtaier
Modified: 2019-09-25 21:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:28:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot with correct behavior for 6.1.z version (35.77 KB, image/png)
2016-03-21 14:27 UTC, Oleksandr Shtaier
no flags Details
Screenshot with error for 6.2 (67.59 KB, image/png)
2016-03-21 14:28 UTC, Oleksandr Shtaier
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14391 None None None 2016-04-22 14:59:49 UTC
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Oleksandr Shtaier 2016-03-21 14:24:37 UTC
Description of problem:
Trying to open docker compute resource through compute profile interface. Get an exception in result

Version-Release number of selected component (if applicable):
6.2 SNAP4

How reproducible:
Always

Steps to Reproduce:
- Go to Infrastructure->Compute Resources
- Push 'New Compute Resource' button
- Input name
- Choose 'Docker' as a provider
- Specify 'http://localhost:2375' (for example) value in URL field
- Push 'Submit' button
- Go to Infrastructure->Compute Profiles
- Choose '1-Small' profile
- Select compute resource entity that was just created

Actual results:
Exception error is raised

Expected results:
Corresponding entity configuration is shown

Additional info:

Comment 1 Oleksandr Shtaier 2016-03-21 14:27:35 UTC
Created attachment 1138614 [details]
Screenshot with correct behavior for 6.1.z version

Comment 2 Oleksandr Shtaier 2016-03-21 14:28:04 UTC
Created attachment 1138615 [details]
Screenshot with error for 6.2

Comment 3 Oleksandr Shtaier 2016-03-21 14:30:16 UTC
There are no connection to https://bugzilla.redhat.com/show_bug.cgi?id=1223405. Just in case

Comment 5 Daniel Lobato Garcia 2016-03-30 07:12:00 UTC
Under review at https://github.com/theforeman/foreman-docker/pull/149

Comment 6 Bryan Kearney 2016-03-30 14:06:53 UTC
Upstream bug component is Container Management

Comment 7 Bryan Kearney 2016-04-01 18:09:22 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14391 has been closed
-------------
Daniel Lobato Garcia
Applied in changeset commit:foreman-docker|1aa3ddb3039a135fc7d303e69c5a389f84dc9ed3.

Comment 8 jcallaha 2016-04-06 19:41:26 UTC
Verified in Satellite 6.2 Beta Snap 6 Compose 2.

You can no longer choose Docker compute resources from the VM Attributes.

Comment 10 errata-xmlrpc 2016-07-27 09:28:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.