Bug 1319908 - Cannot publish content view with docker repository.
Summary: Cannot publish content view with docker repository.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Lukas Pramuk
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-21 19:14 UTC by Zach Huntington-Meath
Modified: 2019-09-26 14:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:28:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14305 None None None 2016-04-22 15:56:42 UTC
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Zach Huntington-Meath 2016-03-21 19:14:37 UTC
How to replicate:

1. Create a new docker repository (I used the default url: https://registry-1.docker.io/ and busybox as upstream repository name.)

2. Sync the new repository.

3. Create a new content view and assign it the docker repository.

4. Publish the content view, it should give the error: Validation failed: Repository URL or Upstream Name is empty. Both are required for syncing from the upstream.

Comment 1 Zach Huntington-Meath 2016-03-21 19:14:39 UTC
Created from redmine issue http://projects.theforeman.org/issues/14305

Comment 3 Bryan Kearney 2016-03-21 22:06:18 UTC
Upstream bug component is Content Views

Comment 4 Brad Buckingham 2016-03-21 22:09:50 UTC
Upstream Katello PR: https://github.com/Katello/katello/pull/5908

Comment 5 Lukas Pramuk 2016-03-24 11:57:46 UTC
VERIFIED.

@Sat6.2.0-Beta-Snap5

Used manual reproducer in comment#0:
Successfully published Docker View version 1.0 and promoted to Library

Comment 8 errata-xmlrpc 2016-07-27 09:28:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.