Bug 1319927 - [RFE] subscription-manager should automatically enable yum plugins
Summary: [RFE] subscription-manager should automatically enable yum plugins
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager   
(Show other bugs)
Version: 7.1
Hardware: Unspecified Unspecified
medium
medium
Target Milestone: rc
: 7.4
Assignee: Jiri Hnidek
QA Contact: John Sefler
Filip Hanzelka
URL:
Whiteboard:
Keywords: FutureFeature, Triaged
Depends On:
Blocks: 1420851 1469152
TreeView+ depends on / blocked
 
Reported: 2016-03-21 20:46 UTC by William
Modified: 2018-05-02 06:57 UTC (History)
9 users (show)

Fixed In Version: subscription-manager-1.20.8-1
Doc Type: Release Note
Doc Text:
*subscription-manager* now automatically enables the `subscription-manager` and `product-id` yum plugins With this update, the *subscription-manager* utility automatically enables the `yum` plugins: `subscription-manager` and `product-id`. This update benefits users of Red Hat Enterprise Linux who previously used the *rhn-client-tools* utility to register their systems to Red Hat Network Classic or who still use it with Satellite 5 entitlement servers, and who have temporarily disabled the `yum` plugins. As a result, it is easier for users to start using the newer *subscription-manager* tools for entitlements. Note that running *subscription-manager* displays a warning message indicating how to change this default behavior if it is not desirable.
Story Points: ---
Clone Of: 1317690
Environment:
Last Closed: 2018-04-10 09:47:31 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1697 None None None 2017-09-04 13:55 UTC
Github candlepin subscription-manager pull 1699 None None None 2017-09-08 16:15 UTC
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:48 UTC
Red Hat Bugzilla 1466453 None None None Never
Red Hat Bugzilla 1513487 None None None Never

Description William 2016-03-21 20:46:44 UTC
Description of problem:

Customers have experienced an issue where setting 'subscription-manager release --set=<version>' did not update the EUS repo to the correct version due to the subscription-manager plugin not being enabled. 

We should have a check to see if the plugin is enabled.  If it is not, then it should provide output stating so and recommend the plugin be enabled.


Version-Release number of selected component (if applicable):
current

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Barnaby Court 2016-03-28 19:13:43 UTC
When setting the release, sub-man should validate that the yum plugin is enabled. There will be no further check after the release has been set.

Comment 3 Chris Snyder 2017-07-10 20:45:24 UTC
Suggestion: The logic to check if the plugin (read from "/etc/yum/pluginconf.d/subscription-manager.conf") is enabled should be run on subman startup. To be clear this means the warning message should be output on any subman command AND on GUI start up.

Comment 10 Shwetha Kallesh 2017-11-14 08:05:38 UTC
Verification :

Case 1.  Verify yum plugins are automatically enabled and user is informed when subscription-manager commands are run on CLI:

[root@dhcp35-121 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.43-1
subscription management rules: 5.26
subscription-manager: 1.20.5-1.el7

Disable the subscription-manager yum plugin:
[root@dhcp35-121 ~]# sed -i s/enabled=./enabled=0/g /etc/yum/pluginconf.d/subscription-manager.conf

Verify if the plugin is disabled:
[root@dhcp35-121 ~]# grep enabled /etc/yum/pluginconf.d/subscription-manager.conf
enabled=0

Now execute the sub-man command on CLI and observe the warning message conveying user that the plugin is enabled automatically:
[root@dhcp35-121 ~]# subscription-manager register 
Registering to: subscription.rhsm.stage.redhat.com:443/subscription
Username: shwetha_tier1_test
Password: 
The system has been registered with ID: 9f559a08-bb1a-49ca-a060-02cc66eba5c0
The registered system name is: dhcp35-121.lab.eng.blr.redhat.com

WARNING

The yum plugins: /etc/yum/pluginconf.d/subscription-manager.conf were automatically enabled for the benefit of Red Hat Subscription Management. If not desired, use "subscription-manager config --rhsm.auto_enable_yum_plugins=0" to block this behavior.

Verify if the plugin is enabled:
[root@dhcp35-121 ~]# grep enabled /etc/yum/pluginconf.d/subscription-manager.conf
enabled=1

Comment 16 errata-xmlrpc 2018-04-10 09:47:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.