Bug 132002 - BAD: kerberos and samba issues
Summary: BAD: kerberos and samba issues
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: krb5   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On: 137614
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-07 18:21 UTC by Tom
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:19:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom 2004-09-07 18:21:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040803

Description of problem:
It would appear that with the latest samba and kerberos libraries
released that there is an issue with accessing samba shares.

The issue is that you must use the FQDN instead of the short name for
the service to work correctly. Apparently, this has to do with the
version of kerberos samba was built against. I apologize for posting
the bug relating it to kerberos, but I thought it was the appropriate
place to start.

Version-Release number of selected component (if applicable):
samba-3.0.6-2.3E krb5-libs-1.2.7-28

How reproducible:
Always

Steps to Reproduce:
1. install latest samba and kerberos
2. configure samba to use ADS
3. attempt to map a share using something other than FQDN
    

Actual Results:  failed

Expected Results:  should connect just fine

Additional info:

Comment 1 Patrick Hopp 2004-09-11 23:35:14 UTC
I've posted to a similar bug report on bugzilla.samba.org here: 
https://bugzilla.samba.org/show_bug.cgi?id=1717

Having exact same problem as person who created the ticket @ 
samba.org.  Redhat AS 3.0, samba quit working after recent upgrade 
from 3.0.4 to 3.0.6.  Log entries are on their website.  Went as far 
as uninstalling samba and krb5 from the box and manually compiled 
krb5 1.3.5 from MIT and Samba 3.0.5, 3.0.6, and latest CVS.  Same 
problem all the way around.  Samba started misbehaving for me after 
the large "quarterly update".  Upgraded a bunch of packages, could be 
any one of the other packages that were upgraded that created this 
problem, but I'm not technical enough to determine which one.

Comment 2 Charles Tran 2004-09-13 17:58:36 UTC
Check out this thread..

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=114938


Comment 3 RHEL Product and Program Management 2007-10-19 19:19:09 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.