Bug 1320024 - Client's App is having issues retrieving files from share 1002976973
Summary: Client's App is having issues retrieving files from share 1002976973
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.7.9
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On: 1318093 1318158
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-22 07:12 UTC by Vijaikumar Mallikarjuna
Modified: 2016-05-11 22:49 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.10
Doc Type: Bug Fix
Doc Text:
Clone Of: 1318158
Environment:
Last Closed: 2016-04-19 07:00:16 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-03-22 07:13:27 UTC
REVIEW: http://review.gluster.org/13804 (marker: set inode ctx before lookup unwind) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Vijay Bellur 2016-03-23 03:48:33 UTC
COMMIT: http://review.gluster.org/13804 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 5d134598103a7563c9ea96d7ed19a0d675a83ab9
Author: vmallika <vmallika@redhat.com>
Date:   Wed Mar 16 13:31:10 2016 +0530

    marker: set inode ctx before lookup unwind
    
    This is a backport of http://review.gluster.org/13748
    
    When a file is unlinked before it was accounted by the marker,
    then we may see error "ctx for the node ... is NULL" at many places.
    This is actually not an error and can be ignored.
    
    It is better to set the inode ctx before lookup/create is unwind
    back to protocol server
    
    > Change-Id: I462b5542951f2fc2964f59af7a31978979dab1de
    > BUG: 1318158
    > Signed-off-by: vmallika <vmallika@redhat.com>
    > Reviewed-on: http://review.gluster.org/13748
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    Change-Id: I04b03e3caefc7fbd5e79b3f73980e2ccb0cb57f5
    BUG: 1320024
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13804
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 3 Kaushal 2016-04-19 07:00:16 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.10, please open a new bug report.

glusterfs-3.7.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026164.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.