Bug 1320025 - registering guest on unregistered host consumes regular instead of flex entitlement with spacewalk-backend-2.3.3-39.el6sat
Summary: registering guest on unregistered host consumes regular instead of flex entit...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration
Version: 570
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Jan Dobes
QA Contact: Ales Dujicek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-22 07:17 UTC by Jan Hutař
Modified: 2019-11-14 07:38 UTC (History)
11 users (show)

Fixed In Version: spacewalk-backend-2.3.3-40-sat
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-02 12:33:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1301137 0 unspecified CLOSED rhnVirtualInstance uuid is not updated on system re-activation 2021-02-22 00:41:40 UTC
Red Hat Knowledge Base (Solution) 18134 0 None None None 2016-04-06 08:10:37 UTC
Red Hat Product Errata RHBA-2016:1200 0 normal SHIPPED_LIVE Satellite 5.7 bug fix update 2016-06-02 16:32:31 UTC

Internal Links: 1301137

Description Jan Hutař 2016-03-22 07:17:21 UTC
Description of problem:
Registering guest (running on unregistered host) consumes regular instead of flex entitlement with spacewalk-backend-2.3.3-39.el6sat.


Version-Release number of selected component (if applicable):
spacewalk-backend-2.3.3-39.el6sat.noarch


How reproducible:
always


Steps to Reproduce:
0. Ensure you are on virtual system (whose host is not registered into
   same Satellite):
     # grep -e QEMU -e KVM /proc/cpuinfo 
     model name	: QEMU Virtual CPU version (cpu64-rhel6)
     model name	: QEMU Virtual CPU version (cpu64-rhel6)
1. with spacewalk-backend-2.3.3-33.el6sat.noarch:
     # rhnreg_ks --force --username=<user> --password=<pass>
   API org.listSoftwareEntitlements(key) returns:
     {'unallocated_flex': 999, 'used': 0, 'name': 'Red Hat Enterprise Linux Server (v. 6)', 'allocated_flex': 1, 'used_flex': 1, 'free': 0, 'label': 'rhel-server-6', 'free_flex': 0, 'unallocated': 14000, 'allocated': 0}
     => GOOD, Flex entitlement is used
2. with spacewalk-backend-2.3.3-39.el6sat.noarch:
     # rhnreg_ks --force --username=<user> --password=<pass>
   API org.listSoftwareEntitlements(key) returns:
     {'unallocated_flex': 1000, 'used': 1, 'name': 'Red Hat Enterprise Linux Server (v. 6)', 'allocated_flex': 0, 'used_flex': 0, 'free': 0, 'label': 'rhel-server-6', 'free_flex': 0, 'unallocated': 13999, 'allocated': 1}
     => BAD, regular entitlement is used


Actual results:
On latest version of the package, guest does not consume flex entitlements


Expected results:
Should consume flex entitlement.

Comment 2 Jan Hutař 2016-03-22 11:09:39 UTC
As a workaround you can always go to Overview -> Subscription Management ->  Virtualization Entitlements -> Guests Consuming Regular Entitlements and switch systems to use FLEX manually.

Comment 5 Jan Dobes 2016-03-22 16:51:54 UTC
fixed in spacewalk master (even if the problem is not there):

fc626e08c34b0be7925a15c4a29236c5cfcf3181

Comment 15 errata-xmlrpc 2016-06-02 12:33:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1200


Note You need to log in before you can comment on or make changes to this bug.