Bug 1320225 - "Errata by id" exclude filter does not seem to exclude errata
Summary: "Errata by id" exclude filter does not seem to exclude errata
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-22 15:26 UTC by Justin Sherrill
Modified: 2019-09-26 14:46 UTC (History)
13 users (show)

Fixed In Version: pulp-2.8.1.3-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:28:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Pulp Redmine 1784 High CLOSED - CURRENTRELEASE regression: "pulp-admin rpm repo search" with filters does not work as expected 2016-05-17 20:01:13 UTC

Description Justin Sherrill 2016-03-22 15:26:01 UTC
Description of problem:

"Errata by id" exclude filter does not seem to be working properly


Version-Release number of selected component (if applicable):
6.2 snap4

How reproducible:
always

Steps to Reproduce:
1.  Create and sync a repo (such as https://jlsherrill.fedorapeople.org/fake-repos/needed-errata/)
2.  Add the repo to a content view
3.  Add an errata by id exclude filter and select the 'sea erratum' 
4.  Publish the content view

Actual results:
Generated version still includes the excluded erratum and packages

Expected results:
Errata and none of its packages are in the published version

Additional info:

Comment 2 pulp-infra@redhat.com 2016-03-23 18:00:52 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 3 pulp-infra@redhat.com 2016-03-23 18:00:54 UTC
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.

Comment 4 pulp-infra@redhat.com 2016-03-28 20:33:36 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 6 pulp-infra@redhat.com 2016-04-06 13:33:39 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 7 Mike McCune 2016-04-08 13:47:46 UTC
This downstream merge causes this error upon syncing content:

pulp.server.webservices.middleware.exception:ERROR: (10716-95680)   File "/usr/lib64/python2.7/site-packages/bson/objectid.py", line 52, in _raise_invalid_id
pulp.server.webservices.middleware.exception:ERROR: (10716-95680)     " or a 24-character hex string" %% oid)
pulp.server.webservices.middleware.exception:ERROR: (10716-95680) InvalidId: '016ba778-1665-4ef7-bc0a-adf99472d6f5' is not a valid ObjectId, it must be a 12-byte input or a 24-character hex string
celery.worker.strategy:INFO: Received task: pulp.server.async.tasks._queue_reserved_task[af6c1d5f-0ebc-4c19-8e2b-c49f4244b0a6]

failing it

Comment 8 Lukas Pramuk 2016-04-18 15:44:54 UTC
VERIFIED.

@Sat6.2.0-Beta-Snap8.2
pulp-*-2.8.1.3-1.el7sat.noarch

used manual reproducer described in comment #0 and I got these CV versions:

Version 1.0
32 Packages
4 Errata ( 3 0 1 )
	
Version 2.0  <- sea erratum excluded by id
29 Packages
3 Errata ( 2 0 1 )
	
Packages/Errata tab counts match with Summary above

Comment 9 pulp-infra@redhat.com 2016-04-26 23:04:16 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 10 pulp-infra@redhat.com 2016-05-06 17:21:03 UTC
The Pulp upstream bug status is at VERIFIED. Updating the external tracker on this bug.

Comment 11 pulp-infra@redhat.com 2016-05-17 20:01:14 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 13 errata-xmlrpc 2016-07-27 09:28:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.