Bug 1320254 - [RFE] Support short abbrevations of commands like install in DNF
Summary: [RFE] Support short abbrevations of commands like install in DNF
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All All
low
unspecified
Target Milestone: ---
Assignee: Martin Hatina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-22 16:36 UTC by Tomáš Chvátal
Modified: 2017-08-02 14:19 UTC (History)
7 users (show)

Fixed In Version: dnf-2.6.2-1.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 16:56:02 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomáš Chvátal 2016-03-22 16:36:29 UTC
This issue is mostly feature request.

When using dnf user can issue command like "dnf in wine" which at this point result in information that tells user to use command "dnf install".

Instead of doing this it would be better to know the two letter abbrevations to make it easier for the user. Also esp. since zypper in openSUSE acts almost the same way but supports the two letter codes for operations.

Comment 1 Fedora Admin XMLRPC Client 2016-07-08 09:24:39 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Fedora Update System 2017-07-24 14:51:56 UTC
libdnf-0.9.3-1.fc26 dnf-plugins-core-2.1.3-1.fc26 dnf-2.6.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6f4c06b2d7

Comment 3 Fedora Update System 2017-07-25 04:27:11 UTC
dnf-2.6.2-1.fc26, dnf-plugins-core-2.1.3-1.fc26, libdnf-0.9.3-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6f4c06b2d7

Comment 4 Fedora Update System 2017-07-25 16:56:02 UTC
dnf-2.6.2-1.fc26, dnf-plugins-core-2.1.3-1.fc26, libdnf-0.9.3-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Marek Suchanek 2017-08-01 16:08:56 UTC
Hello Martin,

I'm with the documentation team, though I'm only asking out of my own curiosity.

Is there a plan to document the new, abbreviated commands, e.g. in the man page or in "dnf --help" output?

I could only get a list of the long and short commands by executing
`grep -R aliases /usr/lib/python3.6/site-packages/dnf`.

If you need any help documenting, I'll be glad to assist you.

Thanks,

Marek

Comment 6 Neal Gompa 2017-08-02 02:52:07 UTC
It definitely needs to be documented, that's for sure.

I wrote up a small blurb for Mageia in our wiki[1], but the dnf documentation[2] needs to be updated. Official documentation is managed in GitHub[3].

[1]: https://wiki.mageia.org/en/Using_DNF

[2]: http://dnf.readthedocs.io/en/latest/command_ref.html

[3]: https://github.com/rpm-software-management/dnf/tree/master/doc

Comment 7 Martin Hatina 2017-08-02 08:28:41 UTC
PR for more aliases and documentation: https://github.com/rpm-software-management/dnf/pull/882

Comment 8 Marek Suchanek 2017-08-02 14:19:58 UTC
Hi Martin,

Thanks for adding the aliases to the man page and the docs. Much appreciated.

Marek


Note You need to log in before you can comment on or make changes to this bug.