Bug 132044 - Epiphany crashes when selecting Edit->Toolbar
Epiphany crashes when selecting Edit->Toolbar
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Marco Pesenti Gritti
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-08 03:52 EDT by David Nielsen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 10:08:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2004-09-08 03:52:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
Running Development as of 08-09-04 I get a consistent crash when
trying to edit my epiphany toolbars.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start epiphany
2. go to Edit->Toolbar

    

Actual Results:  Crash with:

(epiphany:3758): Gdk-CRITICAL **: file gdkdraw.c: line 265
(gdk_drawable_set_colormap): assertion `cmap == NULL ||
gdk_drawable_get_depth (drawable) == cmap->visual->depth' failed

(epiphany:3758): Gdk-WARNING **: gdkpixbuf-drawable.c:1248: Source
drawable has no colormap; either pass in a colormap, or set the
colormap on the drawable with gdk_drawable_set_colormap()

(epiphany:3758): Gdk-CRITICAL **: file gdkdraw.c: line 265
(gdk_drawable_set_colormap): assertion `cmap == NULL ||
gdk_drawable_get_depth (drawable) == cmap->visual->depth' failed

(epiphany:3758): Gdk-WARNING **: gdkpixbuf-drawable.c:1248: Source
drawable has no colormap; either pass in a colormap, or set the
colormap on the drawable with gdk_drawable_set_colormap()
The program 'epiphany' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 3933 error_code 8 request_code 70 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)

Program exited with code 01.


Expected Results:  The toolbar editor should pop up

Additional info:
Comment 2 Bryan W Clark 2004-09-20 18:18:05 EDT
Removing from blocking bug 131589, since composite is not on by
default and the YellowPad is not concerned with things that are not
defaults.  Keeping on the FC3 Target tracker.
Comment 3 David Nielsen 2004-09-20 18:23:57 EDT
I noticed some xorg updates the other day in Development so I to the
liberty of trying this one again and it's fixed for me at least.
Comment 4 Bryan W Clark 2004-10-05 12:24:46 EDT
reassigning to marco
Comment 5 Marco Pesenti Gritti 2004-10-08 10:08:52 EDT
Moved upstream

http://bugzilla.gnome.org/show_bug.cgi?id=150259

Note You need to log in before you can comment on or make changes to this bug.