Bug 1320480 - Multihead support in vmware
Summary: Multihead support in vmware
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-vmware
Version: 6.8
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
Marc Muehlfeld
URL:
Whiteboard:
Depends On:
Blocks: 1360926
TreeView+ depends on / blocked
 
Reported: 2016-03-23 10:21 UTC by Martin Krajnak
Modified: 2018-04-02 17:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
The *vmware* driver does not support multiple displays The *vmware* video driver for the X11 window system misses certain features related to multi-display support. As a consequence, Red Hat Enterprise Linux 6 guests running on VMware cannot correctly use multiple displays and only single-display support is available. Please contact Red Hat support for test packages if you require multi-display support.
Clone Of:
Environment:
Last Closed: 2017-12-06 12:18:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1426684 0 unspecified CLOSED [ESXi][RHEL 7]vmware driver is not able to recognize the second monitor 2021-09-09 12:09:43 UTC

Internal Links: 1426684

Description Martin Krajnak 2016-03-23 10:21:53 UTC
Description of problem:
Virtual machine in vmware is not able to use secondary display connected to host computer. The only visible change, after toggling second monitor on is wrong position of mouse cursor.

Version-Release number of selected component (if applicable):
vm-ware player 11,9
kernel-2.6.32-625.el6.x86_64
xorg-x11-drv-vmware-13.1.0-2.el6.x86_64

Setup:
Host machine with 2 monitors (17",23"), both of them properly working.

How reproducible:
always

Steps to Reproduce:
1. run vmware player
2. run rhel 6.8 as VM
3. choose from menu: Virtual Machine -> Enter Full Screen
4. go to the toolbar, which is placed in the middle of the upper part of screen
5. click on little monitor icon

Actual results:
Second monitor is not initiated, mouse click are bit misplaced (clicks are not exactly in place where pointer is)

Expected results:
Should toggle on second monitor and mouse should work properly.

Additional info:
I also tried to play with virtual machine settings in vmware player (specifying the monitor number to two), but result was the same as using the host settings.

Comment 6 Bo Yang 2017-08-04 05:32:50 UTC
(In reply to Martin Krajnak from comment #0)
> Description of problem:
> Virtual machine in vmware is not able to use secondary display connected to
> host computer. The only visible change, after toggling second monitor on is
> wrong position of mouse cursor.
> 
> Version-Release number of selected component (if applicable):
> vm-ware player 11,9
> kernel-2.6.32-625.el6.x86_64
> xorg-x11-drv-vmware-13.1.0-2.el6.x86_64
> 
> Setup:
> Host machine with 2 monitors (17",23"), both of them properly working.
> 
> How reproducible:
> always
> 
> Steps to Reproduce:
> 1. run vmware player
> 2. run rhel 6.8 as VM
> 3. choose from menu: Virtual Machine -> Enter Full Screen
> 4. go to the toolbar, which is placed in the middle of the upper part of
> screen
> 5. click on little monitor icon
> 
> Actual results:
> Second monitor is not initiated, mouse click are bit misplaced (clicks are
> not exactly in place where pointer is)
> 
> Expected results:
> Should toggle on second monitor and mouse should work properly.
> 
> Additional info:
> I also tried to play with virtual machine settings in vmware player
> (specifying the monitor number to two), but result was the same as using the
> host settings.

Hi, Martin

I am a virt QE, Need your help to confirm something. 
Q1. which Vmware product was used in your environment? VMware Workstation and VMware Fusion or vShpere?

I tested with 2 displays in vSphere, need hope it was useful for this issue, not clear they were the same issues

ENV:
Host: ESXi5.5
Guest: RHEL7.3
xorg-x11-drv-vmware: 13.0.2-7
VMWGFX: 2.10.0.0

Steps:
1. Connected two display to Guest
2. Set "Number of displays" to 2
3. Set "Total video memory" to 128
4. Boot Guest

Results:
1. After step 4:
a. RHEL7 "Virtual Machine Console" can detect display-1.

b. Drag "Virtual Machine Console" to display-2, that was ok.

c. Full Screen "Virtual Machine Console" in diplay-2, lead to "Virtual Machine Console" becoming full screen in display-1, and the "Virtual Machine Console" in display-2 still was the original size, mouse / keyboard didn't work


Thanks

Comment 7 Martin Krajnak 2017-08-04 08:32:40 UTC
Hello boyang,

I am looking to your reproducer and same as you I am not sure if we are testing the same features. I reported the bug a while ago so I am not sure about all the details but from my perspective we are using totally different envinronments.

Q1: I was using RHEL 6.8 on both guest and hosts and I was using VMware player which I believe is the only one product which I have access to (I am not sure about that). 

In my case the display-2 wasn't working at all and the input (mouse/keyboard) was working but was working incorrectly. Therefore I think that in this case it might not be the same issue but I am not sure because I don't have the access to environment that was affected by this issue right now and setup would require some time.

I also think that we used different version of xorg packages that might be the reason why are the results different:
xorg-x11-drv-vmware-13.1.0-2.el6.x86_64
xorg-x11-drv-vmware: 13.0.2-7

I am not sure if any of above helps, issue you are describing looks like a different one to me. Please let me know how I can help further.

Comment 8 Martin Krajnak 2017-08-04 08:52:03 UTC
Setting up needinfo that I cleared accidentally

Comment 9 Jan Kurik 2017-12-06 12:18:54 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.