Bug 1320506 - OpenSCAP plugin options are not exposed in installer
Summary: OpenSCAP plugin options are not exposed in installer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-23 11:28 UTC by Marek Hulan
Modified: 2019-09-25 21:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:07:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14327 None None None 2016-04-22 15:58:40 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Marek Hulan 2016-03-23 11:28:54 UTC
Description of problem:

running foreman-installer --help does not list --enable-foreman-plugin-openscap and --enable-foreman-proxy-plugin-openscap arguments so I can't install openscap plugin. It's not present in either of capsule and katello scenarios.


Version-Release number of selected component (if applicable):

6.2 beta snap4
foreman-installer-katello-3.0.0.3-1.el7sat.noarch

How reproducible:

always

Steps to Reproduce:
1. try to install openscap plugin
2.
3.

Actual results:

there are no options for it

Expected results:

openscap plugin is installed

Additional info:

Comment 1 Marek Hulan 2016-03-23 11:32:31 UTC
Created redmine issue http://projects.theforeman.org/issues/14327 from this bug

Comment 3 Bryan Kearney 2016-03-23 13:27:35 UTC
Upstream bug assigned to mhulan@redhat.com

Comment 4 Bryan Kearney 2016-04-01 02:08:28 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14327 has been closed
-------------
Marek Hulán
Applied in changeset commit:katello-installer|8208868751c672c2696b6ec8aea34dcaf6123d3b.

Comment 5 jcallaha 2016-04-07 13:16:35 UTC
Verified in Satellite 6.2 Beta Snap 6 Compose 2.

[root@rhsm-qe-1 ~]# foreman-installer --help | grep scap
    --[no-]enable-foreman-plugin-openscap Enable 'foreman_plugin_openscap' puppet module (default: false)
    --[no-]enable-foreman-proxy-plugin-openscap Enable 'foreman_proxy_plugin_openscap' puppet module (default: false)
= Module foreman_plugin_openscap:
    --foreman-plugin-openscap-configure-openscap-repo  Enable custom yum repo with packages needed for foreman_openscap, (default: true)
= Module foreman_proxy_plugin_openscap:
    --foreman-proxy-plugin-openscap-enabled  enables/disables the plugin (default: true)
    --foreman-proxy-plugin-openscap-listen-on  Proxy feature listens on http, https, or both (default: "https")
    --foreman-proxy-plugin-openscap-openscap-send-log-file  Log file for the forwarding script (default: "/var/log/foreman-proxy/openscap-send.log")
    --foreman-proxy-plugin-openscap-spooldir  Directory where OpenSCAP audits are stored
                                  before they are forwarded to Foreman (default: "/var/spool/foreman-proxy/openscap")
    --foreman-proxy-plugin-openscap-version  plugin package version, it's passed to ensure parameter of package resource

Comment 7 errata-xmlrpc 2016-07-27 09:07:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.