Bug 1320725 - Review Request: phonon-qt5 - Multimedia framework api (Qt 5 version)
Summary: Review Request: phonon-qt5 - Multimedia framework api (Qt 5 version)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: kde-reviews phonon-qt5-backend-gstreamer
TreeView+ depends on / blocked
 
Reported: 2016-03-23 20:20 UTC by Daniel Vrátil
Modified: 2016-08-14 16:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-22 19:57:55 UTC
rdieter: fedora-review+


Attachments (Terms of Use)

Description Daniel Vrátil 2016-03-23 20:20:09 UTC
Spec URL: https://dvratil.fedorapeople.org/kf5/review/phonon-qt5.spec
SRPM URL: https://dvratil.fedorapeople.org/kf5/review/phonon-qt5-4.8.3-1.fc23.src.rpm
Description: Multimedia framework api (Qt 5 version)
Fedora Account System Username: dvratil

This package targets only EPEL7. On Fedora we have a dual qt4/qt5 "phonon" package. On RHEL however the "phonon" package only provides the Qt4 version and we don't have any easy way to include the Qt 5 version in the packaging at this moment, hence this package.

Comment 1 Rex Dieter 2016-03-31 20:10:24 UTC
adjusting product to "Fedora EPEL" to make it more clear the target.

Comment 2 Rex Dieter 2016-03-31 20:12:08 UTC
While we're on the topic, won't you need a phonon-qt5-backend (gstreamer) pkg too ?

Comment 3 Rex Dieter 2016-03-31 20:14:49 UTC
Looks good, based mostly on fedora package (with only qt5 bits of course).

naming: ok

sources: ok

license: ok

scriptlets: ok

macros: ok

Waiting for scratch build...

Comment 4 Rex Dieter 2016-03-31 20:20:06 UTC
build fails

http://koji.fedoraproject.org/koji/taskinfo?taskID=13520577

I suspect we may need to use cmake3 here?

Comment 5 Rex Dieter 2016-03-31 20:29:12 UTC
Confirmed, using
BuildRequies: cmake3

combined with using %{cmake3} macro (instead of %{cmake}), the build succeeds.


Blockers resolved (we'll have to fix it to do any builds anyway), APPROVED

Comment 6 Rex Dieter 2016-03-31 20:31:12 UTC
pkgdb request submitted

Comment 7 Rex Dieter 2016-04-01 16:27:25 UTC
Imported, and got the build fixed, bootstrap mode only for now (until a backend is available)

Comment 8 Fedora Update System 2016-04-07 15:04:30 UTC
phonon-qt5-backend-gstreamer-4.8.2-2.el7 phonon-qt5-4.8.3-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-8e9b956ff2

Comment 9 Fedora Update System 2016-04-08 21:49:48 UTC
phonon-qt5-4.8.3-2.el7, phonon-qt5-backend-gstreamer-4.8.2-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-8e9b956ff2

Comment 10 Fedora Update System 2016-04-22 19:57:51 UTC
phonon-qt5-4.8.3-2.el7, phonon-qt5-backend-gstreamer-4.8.2-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.