Bug 132074 - calc now improperly imports xls spreadsheets
Summary: calc now improperly imports xls spreadsheets
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openoffice.org
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-08 16:32 UTC by John England
Modified: 2007-11-30 22:07 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-09-15 17:42:35 UTC


Attachments (Terms of Use)
original xls spreadsheet (85.00 KB, text/plain)
2004-09-08 16:33 UTC, John England
no flags Details
correctly imported spreadsheet in oo 16.7 (49.35 KB, text/plain)
2004-09-08 16:34 UTC, John England
no flags Details

Description John England 2004-09-08 16:32:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040803

Description of problem:


Version-Release number of selected component (if applicable):
openoffice.org-1.1.0-16.13.EL.i386

How reproducible:
Always

Steps to Reproduce:
1. start oo calc
2. open xls spreadsheet 
3. see that number formats/values and graphs clobbered (10^-29)
    

Actual Results:  Numbers reported as '0' and '' instead of actual values.
Graph line no longer displayed

Expected Results:  Numbers displayed correctly and calculations based
on these numbers performed correctly.
Graphs imported correctly

Additional info:

Previous version on U2: openoffice.org-1.1.0-16.7.EL.i386 did work
correctly!!  See attached spreadsheets completed on Aug 30/31 just
before upgrade to .13.  The .sxc version was a correct import of the
.xls spreadsheet!  Now, the new version doesn't read it correctly.

Comment 1 John England 2004-09-08 16:33:44 UTC
Created attachment 103589 [details]
original xls spreadsheet

Comment 2 John England 2004-09-08 16:34:44 UTC
Created attachment 103590 [details]
correctly imported spreadsheet in oo 16.7

Comment 3 Derek 2004-09-13 14:36:42 UTC
I can verify this bug. All numbers and dates are imported incorrectly
from Excel in version 16.13. 
Workaround: downgrade back to v16.7.



Comment 4 Dan Williams 2004-09-14 15:26:43 UTC
Derek,

Can you try v16.14.EL when it comes out Real Soon Now?

Thanks!
Dan

Comment 5 Dan Williams 2004-09-15 17:42:35 UTC
Fixed in openoffice.org-1.1.0-16.14.EL, now available through RHN.

errata: RHSA-2004:446



Note You need to log in before you can comment on or make changes to this bug.