Bug 1320817 - Over some time Files which were accessible become inaccessible(music files)
Summary: Over some time Files which were accessible become inaccessible(music files)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.7.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard: tier-fuse-nfs-samba
Depends On: 1302355
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-24 04:00 UTC by Raghavendra Bhat
Modified: 2016-04-19 07:12 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.7.11
Doc Type: Bug Fix
Doc Text:
Clone Of: 1302355
Environment:
Last Closed: 2016-04-19 07:12:36 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-05 12:13:47 UTC
REVIEW: http://review.gluster.org/13909 (posix_acl: skip acl_permits for special clients) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Vijay Bellur 2016-04-06 12:13:16 UTC
REVIEW: http://review.gluster.org/13909 (posix_acl: skip acl_permits for special clients) posted (#2) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Vijay Bellur 2016-04-07 01:32:13 UTC
COMMIT: http://review.gluster.org/13909 committed in release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com) 
------
commit 458d4bac9a3e1093640107d7ef76226bfd92dc1a
Author: vmallika <vmallika@redhat.com>
Date:   Sat Apr 2 12:02:22 2016 +0530

    posix_acl: skip acl_permits for special clients
    
    This is a backport of  http://review.gluster.org/13894
    
    > Change-Id: I3f478b7e4ecab517200f50eb09f65a634c029437
    > BUG: 1320818
    > Signed-off-by: vmallika <vmallika@redhat.com>
    > Reviewed-on: http://review.gluster.org/13894
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    
    Change-Id: I5bb727857e94feb4c86574cf2985c71d8b9ad1d7
    BUG: 1320817
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13909
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 4 Kaushal 2016-04-19 07:12:36 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.11, please open a new bug report.

glusterfs-3.7.11 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026321.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.