Bug 1320830 - process exited while connecting to monitor: kvm_init_vcpu failed: Cannot allocate memory
Summary: process exited while connecting to monitor: kvm_init_vcpu failed: Cannot allo...
Keywords:
Status: CLOSED DUPLICATE of bug 1010885
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-24 05:20 UTC by Venkateswara Rao Dokku
Modified: 2016-03-24 10:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-24 10:08:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Venkateswara Rao Dokku 2016-03-24 05:20:50 UTC
Description of problem:
While trying to launch a VM on RHEL 7, with the memory pinning to specific domain, I am getting the following error

error: Failed to start domain VM1
error: internal error: process exited while connecting to monitor: kvm_init_vcpu failed: Cannot allocate memory

XML Snippet: 
<vcpu placement='static'>2</vcpu>
  <cputune>
    <vcpupin vcpu='0' cpuset='8'/>
    <vcpupin vcpu='1' cpuset='9'/>
  </cputune>
  <numatune>
    <memory mode='strict' nodeset='1'/>
  </numatune>

If I replace the nodeset with '0', the VM was launching properly.
I have sufficient memory for both the NUMA nodes & all the NICs were attached to the NUMA node 1.
[root@localhost ~]# virsh freecell 0
0: 63849676 KiB

[root@localhost ~]# virsh freecell 1
1: 64732832 KiB


Version-Release number of selected component (if applicable):
[root@localhost ~]# virsh --version
1.1.1

qemu version: 1.5.3

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Ján Tomko 2016-03-24 10:08:47 UTC

*** This bug has been marked as a duplicate of bug 1010885 ***


Note You need to log in before you can comment on or make changes to this bug.