Bug 1321084 - Syncing capsule causes SSL errors
Summary: Syncing capsule causes SSL errors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: John Mitsch
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1321137
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-24 15:54 UTC by John Mitsch
Modified: 2019-09-26 14:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:28:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
capsule /var/log/messages (2.49 KB, text/plain)
2016-03-24 18:37 UTC, John Mitsch
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 14359 None None None 2016-04-22 16:46:31 UTC

Description John Mitsch 2016-03-24 15:54:16 UTC
Description of problem:
Syncing or communicating with pulp on a capsule throws SSL errors shown here http://fpaste.org/344676/14588347/


Steps to Reproduce:
1.Install a capsule
2.Sync the capsule

Actual results:
Not able to sync the capsule


Expected results:
Can sync and communicate with the capsule fine

Additional info:
The fix can be found here https://gist.github.com/johnpmitsch/3bf490e781156cc9c84a

Comment 1 John Mitsch 2016-03-24 18:37:05 UTC
in /var/log/messages on capsule

Mar 24 13:44:01 sat-r220-05 pulp: pulp.server.controllers.repository:ERROR: (15901-67168) Exception adding distributor to repo [Default_Organization-dev-Capsule-Test-zoo-zoo]; the repo will be deleted

I will attach the full error

Comment 2 John Mitsch 2016-03-24 18:37:43 UTC
Created attachment 1140097 [details]
capsule /var/log/messages

Comment 4 John Mitsch 2016-03-28 12:31:57 UTC
Created redmine issue http://projects.theforeman.org/issues/14359 from this bug

Comment 5 Bryan Kearney 2016-03-28 22:06:06 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14359 has been closed
-------------
John Mitsch
Applied in changeset commit:puppet-capsule|54daeac19cf59da34b7cab6d6e54770b68b8dd2d.

Comment 9 Kedar Bidarkar 2016-04-14 14:46:12 UTC
VERIFIED with sat62-snap7.1 

There were no SSL Errors seen with capsule syncs.

Comment 11 errata-xmlrpc 2016-07-27 09:28:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.