Bug 1321085 - gi.overrides.BlockDev.LVMError: Failed to call the 'PvScan' method on the '/com/redhat/lvmdbus1/Manager' object: GDBus.Error:org.freedesktop.DBus.Python.dbus.exceptions.DBusException: ('com.redhat.lvmdbus1.Manager', 'Device path (/dev/mapper/luks-d8e8d...
Summary: gi.overrides.BlockDev.LVMError: Failed to call the 'PvScan' method on the '/c...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lvm2
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tony Asleson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b8e11dfd3df0ee61c9fd1312c91...
: 1322099 (view as bug list)
Depends On:
Blocks: F25BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2016-03-24 15:55 UTC by David Shea
Modified: 2016-03-29 20:32 UTC (History)
16 users (show)

Fixed In Version: lvm2-2.02.148-1.fc25
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-29 09:42:17 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (3.02 MB, text/plain)
2016-03-24 15:55 UTC, David Shea
no flags Details
File: anaconda.log (165.09 KB, text/plain)
2016-03-24 15:55 UTC, David Shea
no flags Details
File: dnf.log (1.44 KB, text/plain)
2016-03-24 15:55 UTC, David Shea
no flags Details
File: environ (459 bytes, text/plain)
2016-03-24 15:55 UTC, David Shea
no flags Details
File: lsblk_output (3.06 KB, text/plain)
2016-03-24 15:55 UTC, David Shea
no flags Details
File: lvm.log (1.01 MB, text/plain)
2016-03-24 15:55 UTC, David Shea
no flags Details
File: nmcli_dev_list (1.41 KB, text/plain)
2016-03-24 15:55 UTC, David Shea
no flags Details
File: os_info (451 bytes, text/plain)
2016-03-24 15:55 UTC, David Shea
no flags Details
File: storage.log (553.64 KB, text/plain)
2016-03-24 15:55 UTC, David Shea
no flags Details
File: syslog (1.12 MB, text/plain)
2016-03-24 15:55 UTC, David Shea
no flags Details
File: ifcfg.log (1.67 KB, text/plain)
2016-03-24 15:55 UTC, David Shea
no flags Details
File: packaging.log (5.82 KB, text/plain)
2016-03-24 15:55 UTC, David Shea
no flags Details
File: program.log (89.99 KB, application/octet-stream)
2016-03-24 15:55 UTC, David Shea
no flags Details

Description David Shea 2016-03-24 15:55:20 UTC
Description of problem:
Used autopart + encrypted VG in anaconda

Version-Release number of selected component:
anaconda-25.2-1

The following was filed automatically by anaconda:
anaconda 25.2-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/gi/overrides/BlockDev.py", line 416, in wrapped
    raise transform[1](msg)
  File "/usr/lib/python3.5/site-packages/blivet/formats/lvmpv.py", line 121, in _create
    blockdev.lvm.pvscan(self.device)
  File "/usr/lib/python3.5/site-packages/blivet/formats/__init__.py", line 388, in create
    self._create(**kwargs)
  File "/usr/lib/python3.5/site-packages/blivet/deviceaction.py", line 590, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python3.5/site-packages/blivet/actionlist.py", line 280, in process
    action.execute(callbacks)
  File "/usr/lib/python3.5/site-packages/blivet/devicetree.py", line 381, in processActions
    callbacks=callbacks)
  File "/usr/lib/python3.5/site-packages/blivet/blivet.py", line 164, in doIt
    self.devicetree.processActions(callbacks=callbacks)
  File "/usr/lib/python3.5/site-packages/blivet/osinstall.py", line 1096, in turnOnFilesystems
    storage.doIt(callbacks)
  File "/tmp/updates/pyanaconda/install.py", line 201, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall, callbacks=callbacks_reg)
  File "/usr/lib64/python3.5/threading.py", line 862, in run
    self._target(*self._args, **self._kwargs)
  File "/tmp/updates/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
gi.overrides.BlockDev.LVMError: Failed to call the 'PvScan' method on the '/com/redhat/lvmdbus1/Manager' object: GDBus.Error:org.freedesktop.DBus.Python.dbus.exceptions.DBusException: ('com.redhat.lvmdbus1.Manager', 'Device path (/dev/mapper/luks-d8e8d055-9f45-4d2d-af66-a984993cfcfd) has invalid characters, allowable (abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789#+.:=@_\\/%)')

Additional info:
addons:         com_redhat_docker, com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-25-x86_64 quiet updates=http://192.168.100.1/~dshea/updates.img
dnf.rpm.log:    Mar 24 15:47:48 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.6.0-0.rc0.git1.1.fc25.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide

Comment 1 David Shea 2016-03-24 15:55:29 UTC
Created attachment 1140030 [details]
File: anaconda-tb

Comment 2 David Shea 2016-03-24 15:55:31 UTC
Created attachment 1140031 [details]
File: anaconda.log

Comment 3 David Shea 2016-03-24 15:55:32 UTC
Created attachment 1140032 [details]
File: dnf.log

Comment 4 David Shea 2016-03-24 15:55:33 UTC
Created attachment 1140033 [details]
File: environ

Comment 5 David Shea 2016-03-24 15:55:35 UTC
Created attachment 1140034 [details]
File: lsblk_output

Comment 6 David Shea 2016-03-24 15:55:38 UTC
Created attachment 1140035 [details]
File: lvm.log

Comment 7 David Shea 2016-03-24 15:55:39 UTC
Created attachment 1140036 [details]
File: nmcli_dev_list

Comment 8 David Shea 2016-03-24 15:55:40 UTC
Created attachment 1140037 [details]
File: os_info

Comment 9 David Shea 2016-03-24 15:55:43 UTC
Created attachment 1140038 [details]
File: storage.log

Comment 10 David Shea 2016-03-24 15:55:46 UTC
Created attachment 1140039 [details]
File: syslog

Comment 11 David Shea 2016-03-24 15:55:47 UTC
Created attachment 1140040 [details]
File: ifcfg.log

Comment 12 David Shea 2016-03-24 15:55:48 UTC
Created attachment 1140041 [details]
File: packaging.log

Comment 13 David Shea 2016-03-24 15:55:50 UTC
Created attachment 1140042 [details]
File: program.log

Comment 14 David Shea 2016-03-24 15:57:11 UTC
Shouldn't hyphen be in that list of allowable characters?

Comment 15 Tony Asleson 2016-03-24 17:02:06 UTC
(In reply to David Shea from comment #14)
> Shouldn't hyphen be in that list of allowable characters?

Yep, I'll let lvm team define what the allowable set is and update dbus service.

Comment 16 Tony Asleson 2016-03-24 17:03:21 UTC
(In reply to Tony Asleson from comment #15)
> (In reply to David Shea from comment #14)
> > Shouldn't hyphen be in that list of allowable characters?
> 
> Yep, I'll let lvm team define what the allowable set is and update dbus
> service.

Clarification, I'll update the code once I get the allowable character set.

Comment 17 Tony Asleson 2016-03-24 17:32:03 UTC
Allowable characters for name & path according to udev:

0-9,  A-Z,  a-z,  #+-.:=@_, /

Added missing '-'

Change committed upstream:
https://git.fedorahosted.org/cgit/lvm2.git/commit/?id=d243db5466591412a3c99bb5be84e338da9ba4c9

Comment 18 Mike McCune 2016-03-28 23:38:32 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune with any questions

Comment 19 David Shea 2016-03-29 19:46:40 UTC
*** Bug 1322099 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.