Bug 1321089 - Bulk action via remote execution does not work with multiple hosts
Summary: Bulk action via remote execution does not work with multiple hosts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-24 15:58 UTC by Stephen Benjamin
Modified: 2019-09-25 21:18 UTC (History)
4 users (show)

Fixed In Version: rubygem-katello-3.0.0.15-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:28:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 14351 None None None 2016-04-22 16:07:02 UTC

Description Stephen Benjamin 2016-03-24 15:58:51 UTC
Description of problem:
When using remote execution in Katello to perform a bulk action, only the first host has the job scheduled.

Version-Release number of selected component (if applicable):
6.2 latest snap

How reproducible:
Always

Steps to Reproduce:
1. Go to Content Hosts page
2. Select more than 1 content host
3. Click bulk actions
4. Select Packages
5. Enter a package, e.g. vim-enhanced
6. Click dropdown arrow: "Install via remote execution"

Actual results:
Job is only performed on first host

Expected results:
Job is performed on all hosts

Additional info:

Comment 1 Stephen Benjamin 2016-03-24 15:59:49 UTC
Created redmine issue http://projects.theforeman.org/issues/14351 from this bug

Comment 3 Bryan Kearney 2016-03-24 16:12:33 UTC
Upstream bug component is Content Management

Comment 4 Bryan Kearney 2016-03-28 14:12:46 UTC
Upstream bug assigned to stbenjam@redhat.com

Comment 5 Bryan Kearney 2016-04-05 16:12:45 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14351 has been closed
-------------
Stephen Benjamin
Applied in changeset commit:katello|daa7d1526182ba2b9ef348a52db15faee03c94de.

Comment 6 jcallaha 2016-04-11 20:31:09 UTC
Verified in Satellite 6 Compose 7 Snap 1. Bulk actions now are performed on all hosts selected.

Comment 8 errata-xmlrpc 2016-07-27 09:28:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.