Bug 1321102 - Warn if there are not enough IPs in the pool (otherwise deployment hangs)
Summary: Warn if there are not enough IPs in the pool (otherwise deployment hangs)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ga
: 13.0 (Queens)
Assignee: Ana Krivokapic
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-24 16:41 UTC by Udi
Modified: 2018-06-27 13:26 UTC (History)
19 users (show)

Fixed In Version: openstack-tripleo-validations-8.4.0-1.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:26:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 511304 None master: MERGED tripleo-validations: Warn if there are not enough node IPs in pools (I63298a1bdd8ae793ec37070559537497e81b8ca4) 2018-04-04 12:37:57 UTC
Red Hat Product Errata RHEA-2018:2086 normal SHIPPED_LIVE Red Hat OpenStack Platform 13.0 Enhancement Advisory 2018-06-28 19:51:39 UTC

Description Udi 2016-03-24 16:41:22 UTC
Description of problem:
When using the static IP allocation feature, no validations are run to see if there are enough IPs in the pool for the requested number of nodes. The deployment simply hangs until it times out.


Version-Release number of selected component (if applicable):
python-tripleoclient-0.3.1-1.el7ost.noarch
openstack-tripleo-heat-templates-0.8.12-1.el7ost.noarch


How reproducible:
100 %


Steps to Reproduce:
1. In your environment file, create an IP pool for the compute nodes, but make sure you won't have enough for them all. In this example there is only 1 IP:

parameter_defaults:
  NovaComputeIPs:
    internal_api:
      - 10.35.191.100

2. Deploy with more nodes than the pool size


Actual results:
Deployment hangs


Expected results:
User should get a clear error right on the beginning of the deployment, that more IPs are needed in the pool. Deployment should be aborted and not even attempted.

Comment 2 Mike Burns 2016-04-07 21:36:02 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 3 Dan Sneddon 2016-10-14 14:38:50 UTC
While I think this BZ would be good to address, I think the fact that you need to have sufficient IP space in your allocation pools is well documented. I changed the topic of this BZ to indicate that is a feature request.

I think this is best addressed with an addition to the tripleo-validations. I have added this BZ to the list of future enhancements to networking validations in tripleo-validations.

I am setting the target to OSP 11 for now, although it isn't yet clear if this particular enhancement will be able to land in Ocata.

Comment 14 errata-xmlrpc 2018-06-27 13:26:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.