Bug 1321104 - Configuration status is getting marked out of sync incorrectly
Summary: Configuration status is getting marked out of sync incorrectly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Reporting
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Dominic Cleal
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-24 16:46 UTC by Stephen Benjamin
Modified: 2019-09-26 18:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:28:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 13883 None None None 2016-03-28 13:29:11 UTC

Description Stephen Benjamin 2016-03-24 16:46:04 UTC
Description of problem:
Host's last report was 22 minutes ago, but it shows out of sync in the UI.

irb(main):026:0> time_ago_in_words(host.last_report)
=> "25 minutes"
irb(main):027:0> host.get_status(HostStatus::ConfigurationStatus)
=> #<HostStatus::ConfigurationStatus id: 9, type: "HostStatus::ConfigurationStatus", status: 117440512, host_id: 4, reported_at: "2016-03-24 04:21:21">
irb(main):028:0> host.get_status(HostStatus::ConfigurationStatus).to_label
=> "Out of sync"
irb(main):029:0> Setting[:puppet_interval]
=> 30

Version-Release number of selected component (if applicable):
6.2 Snap 5.1

How reproducible:
Always

Steps to Reproduce:
1. Create a host managed by puppet


Actual results:
Some time after the first report shows up, the host will go to out of sync

Expected results:
Host shows OK up to Setting[:puppet_interval] after report

Additional info:

Comment 1 Stephen Benjamin 2016-03-24 16:46:29 UTC
Created redmine issue http://projects.theforeman.org/issues/14352 from this bug

Comment 2 Bryan Kearney 2016-03-24 18:08:48 UTC
Upstream bug component is Provisioning

Comment 3 Bryan Kearney 2016-03-25 08:08:46 UTC
Upstream bug component is Reporting

Comment 4 Brad Buckingham 2016-03-28 13:24:33 UTC
Based on the upstream comment on http://projects.theforeman.org/issues/14352 , I am updating the bugzilla to reference an issue that appears to already solve the behavior raised.  That issue is http://projects.theforeman.org/issues/13883.

Comment 9 sthirugn@redhat.com 2016-04-01 21:36:05 UTC
Verified with 2 hosts (using libvirt compute resource).  Status was shown good after several reports.  (see screenshots)

Verified in Satellite 6.2-beta-snap-6

Comment 14 errata-xmlrpc 2016-07-27 09:28:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.