Bug 1321140 - partition tables are limited to 4096 characters
Summary: partition tables are limited to 4096 characters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning Templates
Version: 6.1.7
Hardware: x86_64
OS: Linux
urgent
urgent vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-24 18:39 UTC by Fotios Tsiadimos
Modified: 2019-06-13 21:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:02:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1938 normal SHIPPED_LIVE Satellite 6.1.10 bug fix update 2016-09-27 12:56:10 UTC
Foreman Issue Tracker 3008 None None None 2016-07-28 11:47:00 UTC

Description Fotios Tsiadimos 2016-03-24 18:39:51 UTC
Description of problem:

Satellite 6.1

The patch removes the limit varchar(4096) which will be released in 6.2. Can we have also a patch for the version 6.1.


foreman=# \d ptables
                                     Table "public.ptables"
   Column   |            Type             |                      Modifiers                       
------------+-----------------------------+------------------------------------------------------
 id         | integer                     | not null default nextval('ptables_id_seq'::regclass)
 name       | character varying(255)      | not null
 layout     | character varying(4096)     | not null   <=== it has a MAX varchar() limit on the table
 created_at | timestamp without time zone | not null
 updated_at | timestamp without time zone | not null
 os_family  | character varying(255)      | 
Indexes:



Always, it is documented in the named foreman issues:
http://projects.theforeman.org/issues/12119
http://projects.theforeman.org/issues/3008

There is also a fix that has been committed for foreman 1.8:
https://github.com/theforeman/foreman/pull/2113/files

Comment 1 Bryan Kearney 2016-04-05 19:31:43 UTC
Satellite 6.2 will be based of off foreman 1.11, and will contain the above fixes. Moving this bug to 6.1.z for consideration.

Comment 2 Evgeni Golov 2016-07-22 10:04:28 UTC
This looks like a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1270181?

Comment 6 Tomas Strachota 2016-07-28 12:08:45 UTC
Created redmine issue http://projects.theforeman.org/issues/15879 from this bug

Comment 10 jcallaha 2016-09-21 14:24:12 UTC
Verified in Satellite 6.1.10. 

Created a new partition table whose layout was 5,976 characters long. No issues presented during creation/editing.

Comment 12 errata-xmlrpc 2016-09-27 09:02:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1938


Note You need to log in before you can comment on or make changes to this bug.