Bug 1321167 - Kickstarts fails using lazy sync after 10 attempts to fetch a package
Summary: Kickstarts fails using lazy sync after 10 attempts to fetch a package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: Lukas Pramuk
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-24 20:17 UTC by David Davis
Modified: 2019-09-26 14:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:07:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14361 None None None 2016-04-22 15:04:00 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description David Davis 2016-03-24 20:17:44 UTC
Description of problem:

It looks like we missed a setting in our squid.conf that allows anaconda to retrieve lazy synced packages:

range_offset_limit none


Version-Release number of selected component (if applicable):

6.2 snap 5


How reproducible:

Not always. Packages can sometimes be fetched if they are saved to the filesystem before anaconda retries a 10th time.


Steps to Reproduce:
1. Download a RHEL kickstart via lazy sync
2. Provision a system using this kickstart
3.

Actual results:

Anaconda fails after 10 attempts to download a package.


Expected results:

Provisioning succeeds


Additional info:

We should probably check our generated squid.conf against pulp's documentation and make sure we aren't missing any other settings.

http://pulp.readthedocs.org/en/latest/user-guide/deferred-download.html

Comment 2 David Davis 2016-03-24 20:31:46 UTC
Related to https://bugzilla.redhat.com/show_bug.cgi?id=1317047

Comment 3 David Davis 2016-03-28 13:19:04 UTC
It looks like in addition to range_offset_limit, we're also not setting the following option:

minimum_object_size 0 kB


I wonder if we need to be?

Comment 4 Partha Aji 2016-03-28 13:25:42 UTC
Created redmine issue http://projects.theforeman.org/issues/14361 from this bug

Comment 5 Bryan Kearney 2016-03-28 14:12:07 UTC
Upstream bug component is WebUI

Comment 6 David Davis 2016-03-28 15:54:30 UTC
Regarding minimum_object_size, the default in squid is 0 kB already but since pulp sets it explicitly (it needs to be 0 kB), I'm going to add it to our squid configuration.

Comment 7 David Davis 2016-03-28 16:12:45 UTC
Upstream PR:

https://github.com/Katello/puppet-pulp/pull/137

Comment 11 Lukas Pramuk 2016-04-04 11:47:46 UTC
VERIFIED.

@Sat6.2.0-Beta-Snap6

0. new settings are applied:
# grep -e range_offset_limit -e minimum_object_size /etc/squid/squid.conf
minimum_object_size            0 kB
range_offset_limit             none

1. synced Red Hat Enterprise Linux 7 Server Kickstart x86_64 7.2 using Download Policy "On Demand" (default)

2. provisioned new host using local libvirt compute resource

3. host OS install finished successfully

Comment 13 errata-xmlrpc 2016-07-27 09:07:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.