Bug 132130 - ps command hang.
ps command hang.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Jason Baron
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-08 22:05 EDT by Jaechul Yoo
Modified: 2013-03-06 00:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-18 11:52:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaechul Yoo 2004-09-08 22:05:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
ps command hang.

The same problem as bugzilla 46937 occurs at HP rx4640(IA64) with 
Redhat AS 2.1(Up
date2), 2.4.18-e.31. It isn't easy to reproduce the problem. I have 
only output of
 strace.

stat("/proc/4410", {st_mode=S_IFDIR|0555, st_size=0, ...}) = 0
open("/proc/4410/stat", O_RDONLY)       = 7
read(7,

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.not easy to reproduce the problem
2.
3.
    

Additional info:

Unfornately customer executes the command much to monitor theirs 
applications.
Comment 1 Suzanne Hillman 2004-09-09 17:56:11 EDT
This looks like something for which you would be best off going
through support. Please call 800-REDHAT1, or go to
https://www.redhat.com/apps/support/
Comment 2 Albert Cahalan 2004-09-12 19:39:38 EDT
This is clearly a kernel problem. Reading the /proc/*/stat
files should never hang; there is nothing ps can do to
handle this problem.
Comment 3 Rik van Riel 2004-09-15 11:45:19 EDT
Jaechul,

next time the problem occurs, could you please:
1) send us the output of sysrq-t
2) send us the output of /sbin/lsmod

thank you, Rik
Comment 4 Suzanne Hillman 2005-01-18 11:52:03 EST
As there has been no additional information in this bug for 4 months,
I'm closing this. If there is new information as requested in comment
#3, feel free to reopen and include the new information.

Note You need to log in before you can comment on or make changes to this bug.