Bug 1321303 - zsh HIST_REDUCE_BLANKS breaks history
Summary: zsh HIST_REDUCE_BLANKS breaks history
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: zsh   
(Show other bugs)
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Kamil Dudka
QA Contact: Jan Kepler
Maxim Svistunov
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-25 10:24 UTC by Marko Myllynen
Modified: 2016-11-03 23:03 UTC (History)
2 users (show)

Fixed In Version: zsh-5.0.2-22.el7
Doc Type: Bug Fix
Doc Text:
Parsing command substitutions no longer corrupts command history Previously, commands having the `$()` command substitution construct were recorded incorrectly in the command history. This bug has been fixed and parsing command substitutions no longer corrupts command history.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 23:03:12 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2152 normal SHIPPED_LIVE zsh bug fix update 2016-11-03 13:13:01 UTC

Description Marko Myllynen 2016-03-25 10:24:09 UTC
Description of problem:
[root@rhel-7-server ~]# useradd -m -s /bin/zsh testuser
[root@rhel-7-server ~]# echo setopt HIST_REDUCE_BLANKS >> /home/testuser/.zshrc
[root@rhel-7-server ~]# su - testuser
[testuser@rhel-7-server]~% for i in $(seq 1 2) ; do echo $i ; done
1
2
[testuser@rhel-7-server]~% for i in seq 1 2) ; do echo $i ; done 

When HIST_REDUCE_BLANKS is in effect, pressing arrow-up after a command which includes $() shows the previous command broken, $( has gone missing.

Version-Release number of selected component (if applicable):
zsh-5.0.2-14.el7.x86_64 (RHEL 6 / Fedora are ok)

Comment 2 Kamil Dudka 2016-03-29 15:23:08 UTC
Thank you for reporting the bug!

It seems to be caused by the fix for bug #1241023.

The following upstream commit fixes it:

https://sourceforge.net/p/zsh/code/ci/f2a2f28f

Comment 7 Marko Myllynen 2016-04-04 12:49:34 UTC
> Fixed In Version: zsh-5.0.2-20.el7

Thanks, I'm happy to confirm the issue is fixed with this version!

Comment 8 Marko Myllynen 2016-05-17 11:11:42 UTC
I'm afraid I found a case where this is still problematic:

# useradd -m -s /bin/zsh testuser
# echo setopt HIST_REDUCE_BLANKS >> /home/testuser/.zshrc
# echo "alias grep='grep --color=tty'" >> /home/testuser/.zshrc
# su - testuser
[testuser@mars]~% for metric in $(pminfo proc | grep cmd); do echo $metric ; done
proc.psinfo.cmd
[testuser@mars]~% for metric in $(pminfo proc | grepgrep --color=tty cmd); do echo $metric ; done
[testuser@mars]~% rpm -q zsh
zsh-5.0.2-20.el7.x86_64
[testuser@mars]~% 

Thanks.

Comment 9 Kamil Dudka 2016-05-17 12:08:04 UTC
Indeed.  I will backport the following upstream commit to fix it:

https://sourceforge.net/p/zsh/code/ci/e34ce851

Comment 11 Marko Myllynen 2016-05-17 15:42:26 UTC
> Fixed In Version: zsh-5.0.2-22.el7

Thanks, I'm happy to confirm the issue is fixed with this version!

Comment 15 errata-xmlrpc 2016-11-03 23:03:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2152.html


Note You need to log in before you can comment on or make changes to this bug.