Bug 1321330 - on i.mx6 systems the console does not start correctly
Summary: on i.mx6 systems the console does not start correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: armv7hl
OS: Linux
high
high
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1321886 (view as bug list)
Depends On:
Blocks: F24BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2016-03-25 14:27 UTC by Dennis Gilmore
Modified: 2016-05-08 10:29 UTC (History)
14 users (show)

Fixed In Version: kernel-4.5.2-302.fc24 kernel-4.5.3-300.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-06 15:39:42 UTC


Attachments (Terms of Use)
bootup-buildin.svg (77.78 KB, image/svg+xml)
2016-04-21 12:47 UTC, billiboy
no flags Details
bootup-modules.svg (88.83 KB, image/svg+xml)
2016-04-21 12:48 UTC, billiboy
no flags Details

Description Dennis Gilmore 2016-03-25 14:27:57 UTC
Description of problem:
imx-ipuv3-crtc does not get autoloaded resulting in no video on i.MX6 systems by default.

Version-Release number of selected component (if applicable):
kernel-core-4.5.0-0.rc7.git0.2.fc24.armv7hl

How reproducible:
always

Steps to Reproduce:
1. boot system
2.
3.

Actual results:
No console on HDMI

Expected results:
console on HDMI

Additional info:
Tried on cubox-i and wandboard quad

Comment 1 Dennis Gilmore 2016-03-25 18:34:40 UTC
This bug effects 4.4.6-200.fc22.armv7hl also

Comment 2 Adam Williamson 2016-03-27 00:24:26 UTC
+1 blocker, those are supported ARM platforms. Alpha criterion "All release-blocking images must boot in their supported configurations." with footnote "Supported ARM platforms are those listed by the ARM team at Architectures/ARM/Supported_Platforms."

Comment 3 Stephen Gallagher 2016-03-29 12:45:40 UTC
+1 Blocker, but I think the criterion is actually: "A system installed without a graphical package set must boot to a state where it is possible to log in through at least one of the default virtual consoles." (since it probably boots but you just can't see it).

Comment 4 Peter Robinson 2016-03-29 14:33:36 UTC
*** Bug 1321886 has been marked as a duplicate of this bug. ***

Comment 5 Kamil Páral 2016-03-29 16:56:47 UTC
Discussed at today's blocker review meeting [1]. Voted as AcceptedBlocker (Beta) - violates Alpha criterion "All release-blocking images must boot in their supported configurations" on several supported ARM platforms (see "Supported ARM platforms" footnote)

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-29

Comment 6 David Jones 2016-04-08 18:50:02 UTC
I have a problem where the system has a TV connected via HDMI, also serial connection.
It starts to boot, but stops with what I believe is a distorted logo 
displayed on the TV, the serial connection states "Trying to boot from MMC"

kernel-4.5.0-302.fc24.armv7hl is affected.
Also kernel-4.6.0-0.rc2.git2.1.fc25.armv7hl

I read an email that Peter Robinson replied to, which appears to be the same problem. The solution provided by the e-mailer was

The crash comes from video_logo() in drivers/video/cfb_console.c.

I added "#undef CONFIG_VIDEO_LOGO" in drivers/video/cfb_console.c
at line 2223 (right before the #ifdef CONFIG_VIDEO_LOGO in that file)
and rebuilt u-boot.

Which allowed the system to continue to boot.

Comment 7 Adam Williamson 2016-04-18 17:33:06 UTC
Peter, where are we with this? It's a Beta blocker, and Beta freeze is tomorrow...

Comment 8 Peter Robinson 2016-04-19 12:51:22 UTC
I have a kernel for testing at https://pbrobinson.fedorapeople.org/arm-kernel/

Comment 9 billiboy 2016-04-21 12:47:35 UTC
Created attachment 1149460 [details]
bootup-buildin.svg

Comment 10 billiboy 2016-04-21 12:48:42 UTC
Created attachment 1149461 [details]
bootup-modules.svg

Comment 11 billiboy 2016-04-21 12:50:56 UTC
FWIW

Tried kernel from https://pbrobinson.fedorapeople.org/arm-kernel/

- HDMI display still not working
- Wrong system time (1970) cause /dev/rtc0 <--> /dev/rtc1 flipping between rtc-pcf8523 and snvs_rtc whichever loads first
- Thermalzone and clock scaling non working (stick to 792 Mhz, not reconfirmed since 4.5.0-rc7 as modules never worked for me)
- Bootup takes 30s with black HDMI display against 15s with HDMI display within less than 1s after kernel load

Guess I will keep using the recompiled kernel package with config-local applied.
See bootup-buildin.svg (my rebuild) and bootup-modules.svg (kernel-4.5.1-300.imx6.1.fc24.armv7hl.rpm) for reference

ps: even with HDMI working with modules you will get a black HDMI monitor while the initrd is loading.

Comment 12 Dennis Gilmore 2016-04-21 17:57:10 UTC
reverting https://lists.freedesktop.org/archives/dri-devel/2015-November/094065.html which landed in 4.4-rc4 enables things to work again.

Comment 13 Peter Robinson 2016-04-27 14:17:39 UTC
kernel-4.5.2-302.fc24 should fix this:

http://koji.fedoraproject.org/koji/taskinfo?taskID=13825120

A 4.5.2-301.imx.2.fc24 scratch build here for those that wish to test:
http://pbrobinson.fedorapeople.org/arm-kernel/

Comment 14 Fedora Update System 2016-04-27 20:46:20 UTC
kernel-4.5.2-302.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d0e6f02aea

Comment 15 Paul Whalen 2016-04-27 22:47:07 UTC
display working on wandboard quad with kernel-4.5.2-302.fc24.

Comment 16 Fedora Update System 2016-04-28 16:25:51 UTC
kernel-4.5.2-302.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d0e6f02aea

Comment 17 Fedora Update System 2016-05-03 18:05:05 UTC
kernel-4.5.2-302.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-05-05 12:15:31 UTC
kernel-4.5.3-300.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4ce97823af

Comment 19 Fedora Update System 2016-05-06 11:28:10 UTC
kernel-4.5.3-300.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4ce97823af

Comment 20 Adam Williamson 2016-05-06 15:39:42 UTC
Stupid Bodhi, this was already fixed.

Comment 21 Fedora Update System 2016-05-08 10:28:36 UTC
kernel-4.5.3-300.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.