Bug 1321376 - [abrt] krop: krop.py:18:<module>:ImportError: No module named 'version'
Summary: [abrt] krop: krop.py:18:<module>:ImportError: No module named 'version'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: krop
Version: 23
Hardware: x86_64
OS: Unspecified
high
urgent
Target Milestone: ---
Assignee: Tomáš Hozza 🤓
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:5ae768df6547538713234fb44cc...
: 1384191 (view as bug list)
Depends On:
Blocks: 1276890 1370721
TreeView+ depends on / blocked
 
Reported: 2016-03-25 22:50 UTC by Giulio 'juliuxpigface'
Modified: 2016-11-19 21:01 UTC (History)
4 users (show)

Fixed In Version: krop-0.4.9-6.fc24 krop-0.4.9-5.fc23 krop-0.4.11-3.fc24 krop-0.4.11-3.fc25
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-14 20:58:42 UTC


Attachments (Terms of Use)
File: backtrace (7.06 KB, text/plain)
2016-03-25 22:50 UTC, Giulio 'juliuxpigface'
no flags Details
File: environ (3.72 KB, text/plain)
2016-03-25 22:50 UTC, Giulio 'juliuxpigface'
no flags Details

Description Giulio 'juliuxpigface' 2016-03-25 22:50:49 UTC
Description of problem:
Krop crashes on startup, because it doesn't find the module 'version'.

Version-Release number of selected component:
krop-0.4.9-3.fc24

Additional info:
reporter:       libreport-2.6.4
cmdline:        /usr/bin/python3 -s /usr/bin/krop
executable:     /usr/bin/krop
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
#1 <module> in /usr/lib/python3.5/site-packages/krop/krop.py:18
#2 <module> in /usr/bin/krop:17

Comment 1 Giulio 'juliuxpigface' 2016-03-25 22:50:55 UTC
Created attachment 1140458 [details]
File: backtrace

Comment 2 Giulio 'juliuxpigface' 2016-03-25 22:50:56 UTC
Created attachment 1140459 [details]
File: environ

Comment 3 Raphael Groner 2016-03-26 06:45:43 UTC
Thanks for your report. That seems somehow related to PEP 0396.
https://www.python.org/dev/peps/pep-0396/

Though,
> grep version /usr/lib/python3.4/site-packages/krop/version.py 
__version__ = '0.4.9'

Comment 4 Raphael Groner 2016-04-21 12:09:54 UTC
From man python3:

       -s     Don't add user site directory to sys.path.

Then it's obvious that site-packages do not get found.

Comment 5 Giulio 'juliuxpigface' 2016-04-22 19:28:55 UTC
Sorry, but I don't think we can close this so easily...


1) Krop does not work when launched with the appropriate application icon.


2) Also... Take a look to this output:

$ cat /usr/share/applications/krop.desktop | grep -i exec
TryExec=krop
Exec=krop %F

So... I'd assume that "krop" and "krop %F" are the right command. But both fail with the crash reported in the description of this report.


If this isn't the right command for Krop, then IMHO the ".desktop" file should be updated accordingly.

Comment 6 Raphael Groner 2016-04-24 11:44:48 UTC
> head -1 /usr/bin/krop 
#!/usr/bin/python3 -s

No idea why upstream does not like to use site-packages.

Comment 7 Raphael Groner 2016-04-24 16:22:15 UTC
This bug is driving me crazy. Not reproducible with python2 instead of python3.

Comment 8 Raphael Groner 2016-04-25 09:10:37 UTC
Betreff: 
Re: krop and python3
Von: 
Avram Lubkin <aviso@rockhopper.net>
Datum: 
24.04.2016 19:21
An: 
Fedora Python SIG <python-devel@lists.fedoraproject.org>

Based on the error and looking at the source, you should just need to fix the line in /usr/lib/python3.4/site-packages/krop/krop.py:

    parser = ArgumentParser(description=__doc__, version=__version__,

with

    parser = ArgumentParser(description=__doc__,

ArgumentParser does not accept a version keyword
It doesn't in 2.7 either, but it may handle it in in a way that wouldn't cause an errror.


Looks like the version argument was deprecated and later removed. The version of argparse 2.7 is using includes it with a deprecation warning and the version for 3.4 has it removed.

Comment 9 Raphael Groner 2016-05-01 16:21:33 UTC
Unfortunately, I've already pushed the b0rken update to f23 stable.
Sorry about that.

Comment 10 Raphael Groner 2016-05-06 17:28:05 UTC
There are also issues with python3-qt4, besides python3 itself. I'll revert to python2 to ensure a working package.

Comment 11 Fedora Update System 2016-05-06 17:50:52 UTC
krop-0.4.9-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-56449a7e56

Comment 12 Fedora Update System 2016-05-06 19:22:22 UTC
krop-0.4.9-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-04719ee06f

Comment 13 Fedora Update System 2016-05-07 16:55:37 UTC
krop-0.4.9-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-56449a7e56

Comment 14 Fedora Update System 2016-05-07 17:26:42 UTC
krop-0.4.9-6.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-04719ee06f

Comment 15 Fedora Update System 2016-05-11 10:25:27 UTC
krop-0.4.9-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-04719ee06f

Comment 16 Fedora Update System 2016-05-12 09:44:44 UTC
krop-0.4.9-6.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-04719ee06f

Comment 17 Fedora Update System 2016-05-16 16:28:38 UTC
krop-0.4.9-6.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-05-16 22:27:01 UTC
krop-0.4.9-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Giuseppe Castagna 2016-10-04 10:39:17 UTC
The error is back again in krop-0.4.11-2.fc24.noarch 

Traceback (most recent call last):
  File "/usr/bin/krop", line 17, in <module>
    import krop.krop
  File "/usr/lib/python3.5/site-packages/krop/krop.py", line 19, in <module>
    from version import __version__
ImportError: No module named 'version'

Downgraded to krop-0.4.9-6.fc24.noarch and it works

Comment 20 Raphael Groner 2016-10-04 16:59:36 UTC
see also https://bugzilla.redhat.com/show_bug.cgi?id=1370721#c14

Comment 21 Tomáš Hozza 🤓 2016-10-13 08:45:42 UTC
*** Bug 1384191 has been marked as a duplicate of this bug. ***

Comment 22 Tomáš Hozza 🤓 2016-10-13 08:53:42 UTC
Do you plan to revert back to Python2 in near?

Comment 23 Raphael Groner 2016-10-13 18:10:42 UTC
To be honest, I tend to orphan this package.

Long story in short:
I wrote an e-mail to upstream some days ago about the mentioned issue but did not get any response till now, there's no upstream tracker. Upstream has requested me with another e-mail in prior to test with python 3 and it seems to not work in Fedora.

See also past discussion on the mailing list:
https://lists.fedoraproject.org/archives/list/python-devel@lists.fedoraproject.org/thread/KX2PKVEC43OA5ZEVPZIJRV7VYJJAPYCC/#KX2PKVEC43OA5ZEVPZIJRV7VYJJAPYCC

Can you help with the (second) downgrade?

Comment 24 Tomáš Hozza 🤓 2016-10-14 13:45:31 UTC
(In reply to Raphael Groner from comment #23)
> To be honest, I tend to orphan this package.
> 
> Long story in short:
> I wrote an e-mail to upstream some days ago about the mentioned issue but
> did not get any response till now, there's no upstream tracker. Upstream has
> requested me with another e-mail in prior to test with python 3 and it seems
> to not work in Fedora.
> 
> See also past discussion on the mailing list:
> https://lists.fedoraproject.org/archives/list/python-devel@lists.
> fedoraproject.org/thread/KX2PKVEC43OA5ZEVPZIJRV7VYJJAPYCC/
> #KX2PKVEC43OA5ZEVPZIJRV7VYJJAPYCC
> 
> Can you help with the (second) downgrade?

Sure, I'll do the changes in F24+ and submit an update. I would be also willing to maintain the package (my FAS is thozza).

Comment 25 Fedora Admin XMLRPC Client 2016-10-14 17:08:23 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 26 Fedora Update System 2016-10-18 17:28:05 UTC
krop-0.4.11-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5fad5f44ed

Comment 27 Fedora Update System 2016-10-19 08:31:19 UTC
krop-0.4.11-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3b0ce16d2a

Comment 28 Fedora Update System 2016-11-14 20:58:42 UTC
krop-0.4.11-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2016-11-19 21:01:40 UTC
krop-0.4.11-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.