Bug 1321417 - /usr/share/owncloud/occ?
Summary: /usr/share/owncloud/occ?
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: owncloud
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: James Hogarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-26 15:46 UTC by Brian J. Murrell
Modified: 2016-04-24 09:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-24 09:57:00 UTC


Attachments (Terms of Use)

Description Brian J. Murrell 2016-03-26 15:46:12 UTC
Description of problem:
My OwnCloud installation has a large database so upgrades can take a long time.  When this is the case the OwnCloud documentation, webpage and developers recommend using "occ upgrade" to avoid PHP timeouts when doing it at the landing page.

However the occ command seems to be at /usr/share/owncloud/occ without execution permissions.  Not very usable.

Version-Release number of selected component (if applicable):
owncloud-8.0.10-1.el7.noarch


How reproducible:
100%

Steps to Reproduce:
1. None, really.
2.
3.

Actual results:
occ is not in an executable path and not executable.

Expected results:
occ should be in $PATH and should be executable.

Additional info:

Comment 1 James Hogarth 2016-03-26 15:48:45 UTC
This is by design so that it cannot run except explicitly, and it should be run as the apache user.

sudo -u apache php /usr/share/owncloud occ

Comment 2 James Hogarth 2016-03-26 15:49:26 UTC
Just to be clear noticed a slight typo there with the missing /

It should be:

sudo -u apache php /usr/share/owncloud/occ

Comment 3 Brian J. Murrell 2016-03-26 15:55:46 UTC
But why?  If you run it as some user other than apache, it bails out and tells you.

But if you did want to have this restriction/convenience, then why not include a /usr/bin/occ something along the lines of:

------------------------
#!/bin/sh

exec sudo -u apache php /usr/share/owncloud/occ "$@"
------------------------

So as to maintain the usefulness of the recommended "occ" command.

Comment 4 James Hogarth 2016-03-26 16:05:30 UTC
The upstream documentation does not run it directly but being passed to php.

https://doc.owncloud.org/server/8.2/admin_manual/configuration_server/occ_command.html

A script like that would make us differ from upstream documentation and introduce new edge cases (eg only runnable by root without additional configuration) that would be Fedora/EPEL specific.

If occ is used by you sufficiently often that a single occ would be useful to you I suggest you add your script to your systems but it's not an addition I'm willing to carry in the Fedora/EPEL packages for the above reasoning.

Comment 5 Brian J. Murrell 2016-03-26 16:13:49 UTC
When an upgrade needs doing, the OC main page says:

    To avoid timeouts with larger installations, you
    can instead run the following command from your
                 installation directory:
                    ./occ upgrade

That of course does not work on Fedora/EPEL.  Perhaps that at least ought to be updated in Fedora/EPEL packaging to display the correct command rather than leaving it up to admins to figure out what is different?

Comment 6 James Hogarth 2016-03-26 16:16:01 UTC
Now that I can do and will add to the upcoming packages.

Comment 7 Brian J. Murrell 2016-03-26 16:23:22 UTC
That's a fair enough compromise.

Speaking of upcoming... is OC 9 in the near future, for EPEL7 in particular?  :-)

Comment 8 James Hogarth 2016-03-26 16:32:53 UTC
It depends exactly how you define near ...

Have a read through the (long) 9.0.0 is available bug for Fedora:

https://bugzilla.redhat.com/show_bug.cgi?id=1261011

The short version is it is coming - but it will take a while since we need to upgrade from 8.0 to 8.1 first, then from 8.1 to 8.2 and finally up to 9.0 since upstream doesn't support skipping 'major' versions.

I'm doing this in fedora first to flush out issues before looking to the more enteprisey EPEL7 packages (and EPEL6 will be retired soon due to dependency issues).

If you're willing to do some early testing Didier in that thread has a COPR up with the changes I'm making in Fedora mirrored there.

I imagine in the next few months we'll be caught up again and it'll be easier staying up to date then but it depends on $life and how things go in Fedora.

Comment 9 Fedora Update System 2016-04-05 15:51:16 UTC
php-sabre-event-2.0.2-1.el7 php-sabre-vobject-3.5.0-1.el7 php-sabre-http-3.0.5-1.el7 php-sabre-dav-2.1.10-1.el7 owncloud-8.1.6-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-3945697efc

Comment 10 Fedora Update System 2016-04-06 21:20:16 UTC
owncloud-8.1.6-1.el7, php-sabre-dav-2.1.10-1.el7, php-sabre-event-2.0.2-1.el7, php-sabre-http-3.0.5-1.el7, php-sabre-vobject-3.5.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-3945697efc

Comment 11 Fedora Update System 2016-04-24 09:28:29 UTC
owncloud-8.1.6-1.el7, php-sabre-dav-2.1.10-1.el7, php-sabre-event-2.0.2-1.el7, php-sabre-http-3.0.5-1.el7, php-sabre-vobject-3.5.0-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 James Hogarth 2016-04-24 09:57:00 UTC
The version now out has the patch to display the correct command in the web upgrade screen.

As a reminder per my mail to the EPEL and CentOS lists 8.2.3 will be pushed into testing shortly, please make sure you've updated to 8.1.6 before 8.2.3 is pushed live in a few weeks.


Note You need to log in before you can comment on or make changes to this bug.