Bug 1321444 - [z-stream clone] Storage activities are failing with error "Image is not a legal chain"
Summary: [z-stream clone] Storage activities are failing with error "Image is not a le...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.6.3
Hardware: Unspecified
OS: Linux
urgent
high
Target Milestone: ovirt-3.6.4
: ---
Assignee: Adam Litke
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Depends On: 1319987
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-27 06:47 UTC by Allon Mureinik
Modified: 2019-12-16 05:34 UTC (History)
27 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1319987
Environment:
Last Closed: 2016-04-04 01:17:59 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2204741 0 None None None 2016-03-27 06:47:09 UTC
Red Hat Product Errata RHBA-2016:0586 0 normal SHIPPED_LIVE vdsm 3.6.4 bug fix and enhancement update 2016-04-04 05:16:54 UTC
oVirt gerrit 55164 0 None None None 2016-03-27 06:47:09 UTC
oVirt gerrit 55175 0 None None None 2016-03-27 06:47:09 UTC
oVirt gerrit 55227 0 None None None 2016-03-27 06:47:09 UTC
oVirt gerrit 55231 0 None None None 2016-03-27 06:47:09 UTC
oVirt gerrit 55285 0 ovirt-3.6.3 MERGED blockVolume: Remove stale links to image directory 2016-03-27 10:37:22 UTC
oVirt gerrit 55286 0 ovirt-3.6.3 MERGED storage: Clean up image links during teardownImage 2016-03-27 10:39:52 UTC

Comment 3 Elad 2016-03-28 12:29:33 UTC
Tested the following scenario:

1) Created a VM with block storage based disk attached 
2) Started the VM on a non SPM host
3) Selected the host where the VM was running to be SPM
4) Stopped the VM and tried to perform storage operations like template creation and disk extension

Storage operations succeeded.

Tested using the following:
vdsm-4.17.23.2-1.el7ev.noarch
libvirt-daemon-1.2.17-13.el7_2.4.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.10.x86_64
rhevm-3.6.4.1-0.1.el6.noarch


Tested also over the following where the issue reproduced ("Image is not a legal chain"):
vdsm-4.17.23.1-0.el7ev.noarch
rhevm-3.6.4-0.1.el6.noarch

Comment 5 errata-xmlrpc 2016-04-04 01:17:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0586


Note You need to log in before you can comment on or make changes to this bug.