Bug 132145 - dos2unix doesn't preserve the file permissions
Summary: dos2unix doesn't preserve the file permissions
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dos2unix   
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-09 07:39 UTC by Péter, Soós
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 00:35:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:195 low SHIPPED_LIVE dos2unix and unix2dos bug fix update 2005-05-19 04:00:00 UTC

Description Péter, Soós 2004-09-09 07:39:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; hu-HU; rv:1.7.2)
Gecko/20040803

Description of problem:
It seems like dos2unix doesn't preserve the file permissions (group
read/write):

$ ls -l proba.txt
-rw-rw-r--  1 sp sp 39 Sep  9 09:24 proba.txt
$ dos2unix proba.txt
dos2unix: converting file proba.txt to UNIX format ...
$ ls -l proba.txt
-rw-------  1 sp sp 37 Sep  9 09:24 proba.txt


Version-Release number of selected component (if applicable):
dos2unix-3.1-17

How reproducible:
Always

Steps to Reproduce:
1. create a file with permissions 664
2. dos2unix it

    

Actual Results:  dos2unix doesn't preserve the file permissions

Expected Results:  dos2unix preserves the file permissions

Additional info:

Comment 1 Mike A. Harris 2004-09-26 09:04:56 UTC

*** This bug has been marked as a duplicate of 91331 ***

Comment 2 Tim Powers 2005-05-20 00:35:36 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-195.html



Note You need to log in before you can comment on or make changes to this bug.