Bug 1321454 - copy/pasting passwords from keepassx (xwayland) to wayland apps doesn't work
Summary: copy/pasting passwords from keepassx (xwayland) to wayland apps doesn't work
Keywords:
Status: CLOSED DUPLICATE of bug 1285342
Alias: None
Product: Fedora
Classification: Fedora
Component: keepassx
Version: 23
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-27 10:21 UTC by Frank Ansari
Modified: 2016-09-02 00:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-02 00:39:53 UTC


Attachments (Terms of Use)

Description Frank Ansari 2016-03-27 10:21:44 UTC
Description of problem:
Copy&paste from keepassx to wayland apps like the gnome terminal does not work.

Version-Release number of selected component (if applicable):
2.0.0

How reproducible:
see below

Steps to Reproduce:
1. Log into Gnome with gnome-wayland session.
2. Then open keepassx and a gnome terminal.
3. Then copy&paste a password from keepassx into the gnome terminal.

Actual results:
This works sometimes but most of the time it does not work.
If I do a right mouse click in the gnome terminal window I see that "Paste" is in grey. So nothing has been put to the clipboard.

Expected results:
Copy&paste should always work.

Additional info:
This is a similar behaviour like keepass as described in #1285342.
Only workaround for me now is to paste the password into another xwayland application (some editor for example) copy it from there and paste it into the gnome terminal. This is of course very unconvenient.

Comment 1 Frank Ansari 2016-05-05 15:31:06 UTC
Any news on this?

Comment 2 Chris Smart 2016-09-02 00:39:53 UTC

*** This bug has been marked as a duplicate of bug 1285342 ***


Note You need to log in before you can comment on or make changes to this bug.