Bug 132147 - xinetd does not listen for IPv6
xinetd does not listen for IPv6
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xinetd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-09 04:19 EDT by Thomas Zehetbauer
Modified: 2014-08-31 19:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:37:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Zehetbauer 2004-09-09 04:19:10 EDT
xinetd-2.3.13-4 does not listen for IPv6 connections by default, even
worse it ignores "flags = IPv6" in /etc/xinetd.conf, one has to add it
to every service in /etc/xinetd.d/.
Comment 1 Rik van Riel 2004-09-24 19:07:14 EDT
Jay, want to add this config change to the shipped xinetd.conf ?

Mind if I add this to the FC3BugWeekTracker ?
Comment 2 Thomas Zehetbauer 2004-09-24 19:22:31 EDT
Unfortunately it is not that easy, we need to either fix xinetd to
respect the flags=IPv6 in /etc/xinetd.conf or to add this line to
every service in /etc/xinetd.d
Comment 3 Steve Grubb 2005-03-22 13:29:56 EST
I'm the upstream maintainer of xinetd. The xinetd.conf man pages state what
attributes can be default. flags is not one of them. The flags attribute was
intended to be a per service tweek. Some of the options in flags can make bad
things happen if they were inherited. For example, nameinargs or sensor.

To solve your problem, put a flags = IPv6 in each service that you want to
listen on IPv6.
Comment 4 Thomas Zehetbauer 2005-03-22 15:10:03 EST
Unix has a tradition of giving its users plenty of rope to hang themselves.
Having flags that make bad things happen may be a bad design but it does not
justify disabling a functionality that has its valid use.

Most programs support IPv6 by default if available at compile time, I think that
xinetd should follow this example. Setting "flags = IPv6" in the defaults
section or specifying a command line flag would be an acceptable solution.
Having to ass "flags = IPv6" in every single configuration file is just a pain
that effects dozens of package maintainers from Fedora and elsewhere.
Comment 5 Jay Fenlason 2005-03-22 15:30:48 EST
PTC.  Your best bet for getting such a patch accepted upstream will be to 
split flags into two configuration options, one of which contains only flags 
that make at least some sense to set as defaults (and can be listed there), 
and another that contains per-service-only flags.  Don't forget to update the 
documentation too. 
Comment 6 Steve Grubb 2005-03-22 17:52:56 EST
>Setting "flags = IPv6" in the defaults section or specifying a command line 
>flag would be an acceptable solution.

I'll think about it. Xinetd is not under heavy development these days. We are
only making small changes. Its basically "done".

>Having to pass "flags = IPv6" in every single configuration file is just a pain
>that effects dozens of package maintainers from Fedora and elsewhere.

This doesn't affect any package maintainers. They have no idea what anyone's
machine is running nor should they. This is a site customization for the local
admin.

I'll mull over this request and see how big the changes are.
Comment 7 Thomas Zehetbauer 2005-03-22 19:01:06 EST
I guess you are right, xinetd is pretty much done for IPv4, but the Internet is
transitioning to IPv6 and when a site administrator enables a service it should
be enabled for both IPv4 and IPv6 unless explicitly told otherwise.
Unfortunately xinetd's current IPv6 support looks more like a hack. For Fedora
or any other Linux distribution to support IPv6 each package that depends on
xinetd must be changed to include "flags=IPv6".

Note You need to log in before you can comment on or make changes to this bug.