Bug 132150 - PANIC: handle_group_exit
PANIC: handle_group_exit
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: strace (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-09 04:44 EDT by Roland McGrath
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 23:09:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
test program; gcc -lpthread (163 bytes, text/plain)
2004-09-09 04:45 EDT, Roland McGrath
no flags Details

  None (edit)
Description Roland McGrath 2004-09-09 04:44:58 EDT
Description of problem:

PANIC: attached pid 2092 exited
PANIC: handle_group_exit: 2092 leader 2091

Version-Release number of selected component (if applicable):

current

How reproducible:
100%

Steps to Reproduce:
1. see attached; compile with -lpthread
2. strace -f foobar
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Roland McGrath 2004-09-09 04:45:41 EDT
Created attachment 103628 [details]
test program; gcc -lpthread
Comment 2 Dmitry V. Levin 2004-09-12 18:12:43 EDT
Unable to reproduce on linuxthreads.  NPTL-enabled kernel?
Comment 3 Roland McGrath 2004-10-19 23:09:04 EDT
Fixed in 4.5.8
Comment 4 Tim Powers 2005-05-19 17:09:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-131.html

Note You need to log in before you can comment on or make changes to this bug.