Bug 132154 - application uses obsolete OSS audio interface
application uses obsolete OSS audio interface
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-09 07:09 EDT by Pawel Orzechowski
Modified: 2015-01-04 17:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 17:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pawel Orzechowski 2004-09-09 07:09:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
Following messages occur in /var/log/messages file. Maybe these are just warnings, but since I'm not sure if they have impact on the system I'm reporting this as a bug.

kernel: application realplay.bin uses obsolete OSS audio interface
kernel: application nspluginviewer uses obsolete OSS audio interface
kernel: application wine-preloader uses obsolete OSS audio interface
kernel: application audacity uses obsolete OSS audio interface


Version-Release number of selected component (if applicable):
kernel-2.6.8-1.521

How reproducible:
Always

Steps to Reproduce:
1.Start any of following applications (wine, realplayer, audacity)
2.Look into /var/log/messages file
    

Actual Results:  There is inscription in /var/log/messages file:
"application <appname> uses obsolete OSS audio interface"

Expected Results:  nothing

Additional info:
Comment 1 Arjan van de Ven 2004-09-09 08:33:59 EDT
the kernel spews these messages to so that the owners of the programs
get notified they haven't converted to the new ALSA interfaces yet.

the goal for fedora is to move all our own software to the new alsa
interfaces; this is a debug trap to make sure we catch everything

Note You need to log in before you can comment on or make changes to this bug.