Bug 1321578 - auth.allow and auth.reject not working host mentioned with hostnames/FQDN
Summary: auth.allow and auth.reject not working host mentioned with hostnames/FQDN
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: protocol
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mohit Agrawal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-28 13:08 UTC by Gaurav Kumar Garg
Modified: 2018-02-20 10:00 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1319271
Environment:
Last Closed: 2017-05-30 18:34:38 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Gaurav Kumar Garg 2016-03-28 13:08:54 UTC
+++ This bug was initially created as a clone of Bug #1319271 +++

Description of problem:
-----------------------
auth.allow and auth.reject not taking in values of hostnames when mentioned with FQDNs, but works with IPv4

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.1

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. Set auth.allow or auth.reject with FQDN

Actual results:
---------------
auth.allow or auth.reject doesn't work with the hostnames when provided with FQDN 

Expected results:
-----------------
auth.allow or auth.reject should accept/respect the hostnames when provided with FQDN

Comment 1 Vijay Bellur 2016-03-28 13:18:46 UTC
REVIEW: http://review.gluster.org/13835 (protocol: resolve hostname or ip address properly while authentication) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 2 Mike McCune 2016-03-28 22:23:05 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 3 Vijay Bellur 2016-03-29 07:38:06 UTC
REVIEW: http://review.gluster.org/13835 (protocol: resolve hostname or ip address properly while authentication) posted (#2) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 4 Vijay Bellur 2016-03-29 09:38:33 UTC
REVIEW: http://review.gluster.org/13835 (protocol: resolve hostname or ip address properly while authentication) posted (#3) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 5 Vijay Bellur 2016-03-30 06:25:55 UTC
REVIEW: http://review.gluster.org/13835 (protocol: resolve hostname or ip address properly while authentication) posted (#4) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 8 Vijay Bellur 2016-08-04 10:12:15 UTC
REVIEW: http://review.gluster.org/15086 (cli : auth.allow and auth.reject does not accept FQDN/host name) posted (#1) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 9 Vijay Bellur 2016-08-04 10:14:42 UTC
REVIEW: http://review.gluster.org/15086 (cli : auth.allow and auth.reject does not accept FQDN/host name) posted (#2) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 10 Vijay Bellur 2016-08-04 10:17:27 UTC
REVIEW: http://review.gluster.org/15086 (cli : auth.allow and auth.reject does not accept FQDN/host name) posted (#3) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 11 Vijay Bellur 2016-08-06 12:46:12 UTC
REVIEW: http://review.gluster.org/15086 (cli/auth : auth.allow and auth.reject does not accept FQDN/host name) posted (#4) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 12 Vijay Bellur 2016-08-10 07:54:40 UTC
REVIEW: http://review.gluster.org/15086 (cli/auth : auth.allow and auth.reject does not accept FQDN/host name) posted (#5) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 13 Worker Ant 2016-09-06 08:55:50 UTC
REVIEW: http://review.gluster.org/15086 (cli/auth : auth.allow and auth.reject does not accept FQDN/host name) posted (#6) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 14 Worker Ant 2016-09-09 03:55:47 UTC
REVIEW: http://review.gluster.org/15086 (cli/auth : auth.allow and auth.reject does not accept FQDN/host name) posted (#7) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 15 Worker Ant 2017-03-30 09:16:47 UTC
REVIEW: https://review.gluster.org/15086 (cli/auth : auth.allow and auth.reject does not accept FQDN/host name) posted (#8) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 16 Worker Ant 2017-04-10 05:10:32 UTC
COMMIT: https://review.gluster.org/15086 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit c7ba4b2b1a1cca6f217083ff9c1f01f23c9ca171
Author: Mohit Agrawal <moagrawa@redhat.com>
Date:   Thu Mar 30 14:45:59 2017 +0530

    cli/auth : auth.allow and auth.reject does not accept FQDN/host name
    
    Problem : At the time of set FQDN name to "auth.allow/auth.reject" through
               gluster cli,it does not accept FQDN/host name.
    
    Solution: Condition needs to be update in verify_host_name and gf_auth
               to accept FQDN/host name.
    
    Fix : Change the condition to accept FQDN/host Name.
          To verify the patch followed below procedure
          1) Try to set FQDN name for auth.allow or auth.reject parameter
             gluster v set myvol auth.reject <fqdn name>
             It gives error "fqdn-name" is not a valid internet-address-list
          2) After apply the patch it does not give any error.
          3) To verify auth.allow/reject try to mount volume on some client.
    
    Change-Id: Ieb76cbb93d43323fd29c7ca04efe3790edb4281b
    BUG: 1321578
    Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>
    Reviewed-on: https://review.gluster.org/15086
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 17 Shyamsundar 2017-05-30 18:34:38 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.