Bug 132158 - 64bit httpd doesn't serve files >2Gb
64bit httpd doesn't serve files >2Gb
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-09-09 08:22 EDT by Karsten Hopp
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 08:44:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2004-09-09 08:22:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
Downloads of large files from apache running on x86_64 fail after
~2Gb:
sendfile(12, 14, [2147205120], 2125864960) = 196608
poll([{fd=12, events=POLLOUT, revents=POLLOUT}], 1, 300000) = 1
sendfile(12, 14, [2147401728], 2125668352) = 81919
poll([{fd=12, events=POLLOUT, revents=POLLOUT}], 1, 300000) = 1
sendfile(12, 14, [2147483647], 2125586433) = -1 EOVERFLOW (Value too large for
defined data type)
write(9, "127.0.0.1 - - [08/Sep/2004:17:29"..., 147) = 147
close(12)                               = 0
read(5, 0x7fbffffa4f, 1)                = -1 EAGAIN (Resource temporarily
unavailable)
close(14)                               = 0
close(13)                               = 0


Version-Release number of selected component (if applicable):
httpd-2.0.50-7

How reproducible:
Always

Steps to Reproduce:
1.install 64bit httpd package on a 64bit machine
2.create a file >2Gb in the html directory
3.try to download the file (preferably from the same or another 64bit
  machine just in case the 32bit client can't handle large files)
4.strace the httpd process to get the above output
    

Actual Results:  downloads fail after 2Gb

Expected Results:  complete download of files >2Gb

Additional info:
Comment 1 Joe Orton 2004-09-09 09:44:05 EDT
Can you try booting e.g. the RHEL3 kernel on this box to see if this
is a regression in 2.6?
Comment 2 Joe Orton 2004-09-09 09:54:53 EDT
I can't see that httpd is doing anything wrong here, this is either a
libc bug, or a kernel bug.

http://www.ussg.iu.edu/hypermail/linux/kernel/0405.2/0547.html

says there was a bug with these symptoms in some kernels.
Comment 3 Karsten Hopp 2004-09-09 10:18:50 EDT
Yes, looks like a kernel problem. Booting the same system with the 
RHEL3-U3 kernel fixed it for me. 
Comment 4 Karsten Hopp 2004-09-14 08:44:12 EDT
I didn't see patch for this, probably hidden in the bk-patch. But 
this works with kernel-2.6.8-1.567smp 

Note You need to log in before you can comment on or make changes to this bug.