Bug 1321589 - unable to export repository directly to /var/www/html/pub/export
Summary: unable to export repository directly to /var/www/html/pub/export
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Chris Duryee
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1314299
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-28 14:20 UTC by Chris Duryee
Modified: 2019-09-25 21:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:29:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 14362 None None None 2016-04-22 15:00:07 UTC

Description Chris Duryee 2016-03-28 14:20:41 UTC
Description of problem:

It is a common use case for users to want to export a repo directly to the '/var/www/html/pub/export' directory. If you attempt this with Sat 6.2 snapshot 5, you'll get an selinux denial.

Version-Release number of selected component (if applicable): snap 5


How reproducible: every time


Steps to Reproduce:
1. create dir with correct permission, and set pulp_export_destination to /var/www/html/pub/export
2. attempt to export a repository

Actual results: error, and selinux denial


Expected results: successful export


Additional info: Exporting directly to /var/www/html/pub/export was not intended as an original use case, but seems popular enough to warrant adding a rule for this.

Comment 3 Bryan Kearney 2016-03-28 22:07:45 UTC
Upstream bug component is Content Management

Comment 4 Bryan Kearney 2016-03-28 22:07:48 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14362 has been closed

Comment 5 jcallaha 2016-04-06 14:11:38 UTC
Verified in Satellite 6.2 Beta Snap 6 Compose 2.

Comment 7 errata-xmlrpc 2016-07-27 09:29:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.