Bug 1321600 - Tag Control issues on service dialogue imports between appliances
Summary: Tag Control issues on service dialogue imports between appliances
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Control
Version: 5.5.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: GA
: 5.5.5
Assignee: eclarizi
QA Contact: Shveta
URL:
Whiteboard: service:dialog
: 1322830 (view as bug list)
Depends On: 1319952 1322830
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-28 15:13 UTC by John Prause
Modified: 2019-12-16 05:34 UTC (History)
8 users (show)

Fixed In Version: 5.5.5.0
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms, exported service dialogues with tag control items had the tag category_id statically assigned, and could have therefore lost their relationship to the tag imported into another appliance if the ID did not match exactly. As a result, there were tag control issues on service dialogue imports between appliances. This update ensures that old import files without a category name will still import. Besides, it also exports category name/description so that imports can utilize them.
Clone Of: 1319952
Environment:
Last Closed: 2016-07-26 15:31:49 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Comment 1 John Prause 2016-03-31 12:19:37 UTC
*** Bug 1322830 has been marked as a duplicate of this bug. ***

Comment 2 CFME Bot 2016-06-13 18:39:25 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=95f5c67d4228c6f2b9bfd75cad555af94bdaac81

commit 95f5c67d4228c6f2b9bfd75cad555af94bdaac81
Author:     Erik Clarizio <eclarizi@redhat.com>
AuthorDate: Mon May 2 07:46:27 2016 -0700
Commit:     Erik Clarizio <eclarizi@redhat.com>
CommitDate: Mon Jun 13 09:44:33 2016 -0700

    Ensure that old import files without a category name will still import
    
    https://github.com/ManageIQ/manageiq/issues/7449
    https://bugzilla.redhat.com/show_bug.cgi?id=1321600

 app/models/dialog_field_importer.rb       | 19 ++++++---
 spec/models/dialog_field_importer_spec.rb | 66 ++++++++++++++++++-------------
 2 files changed, 53 insertions(+), 32 deletions(-)

Comment 3 CFME Bot 2016-06-13 18:39:29 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=3979461cb363c01964905c30ddeb52bd19b2b325

commit 3979461cb363c01964905c30ddeb52bd19b2b325
Author:     Erik Clarizio <eclarizi@redhat.com>
AuthorDate: Tue Mar 29 07:43:14 2016 -0700
Commit:     Erik Clarizio <eclarizi@redhat.com>
CommitDate: Mon Jun 13 09:44:23 2016 -0700

    Export category name/description so that imports can utilize them
    
    https://github.com/ManageIQ/manageiq/issues/7449
    https://bugzilla.redhat.com/show_bug.cgi?id=1321600

 app/models/dialog_field_importer.rb         |  7 ++++
 app/models/dialog_field_serializer.rb       |  5 +++
 spec/models/dialog_field_importer_spec.rb   | 51 ++++++++++++++++++++++++++++-
 spec/models/dialog_field_serializer_spec.rb | 32 ++++++++++++++++--
 4 files changed, 92 insertions(+), 3 deletions(-)

Comment 4 CFME Bot 2016-06-13 18:40:16 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=8269067afd998458de93c9bcbb8f7c5769f300ba

commit 8269067afd998458de93c9bcbb8f7c5769f300ba
Merge: 643ed48 95f5c67
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Mon Jun 13 13:54:55 2016 -0400
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Mon Jun 13 13:54:55 2016 -0400

    Merge branch 'MR-for-PR7574' into '5.5.z'
    
    Fix for Tag Control issues on service dialog imports between appliances
    
    This is the 5.5.z backport for https://bugzilla.redhat.com/show_bug.cgi?id=1319952.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1321600
    
    Cherry-picked from https://github.com/ManageIQ/manageiq/pull/7574
    Cherry-pick was completely clean.
    
    See merge request !962

 app/models/dialog_field_importer.rb         | 16 ++++++++
 app/models/dialog_field_serializer.rb       |  5 +++
 spec/models/dialog_field_importer_spec.rb   | 63 ++++++++++++++++++++++++++++-
 spec/models/dialog_field_serializer_spec.rb | 32 ++++++++++++++-
 4 files changed, 113 insertions(+), 3 deletions(-)

Comment 6 Shveta 2016-07-07 17:50:37 UTC
Created a tag category with same name and description on two appliances. Both got different category Id as shown below.

options:
          :category_id: '124'
          :force_single_value: true
          :sort_by: :description
          :sort_order: :ascending
          :category_name: shveta_tag
          :category_description: sstag


options:
          :category_id: '145'
          :force_single_value: true
          :sort_by: :description
          :sort_order: :ascending
          :category_name: shveta_tag
          :category_description: sstag

Export dialog from one to other appliance. Imported successfully with correct tag category.

Verified in 5.5.5.0.20160628144838_629f93b

Comment 8 errata-xmlrpc 2016-07-26 15:31:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html


Note You need to log in before you can comment on or make changes to this bug.