Bug 1321604 - Hardware.Volumes data not available for VMware VMs
Summary: Hardware.Volumes data not available for VMware VMs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.5.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: GA
: 5.5.5
Assignee: Yuri Rudman
QA Contact: Satyajit Bulage
URL:
Whiteboard:
Depends On: 1319764
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-28 15:19 UTC by John Prause
Modified: 2019-11-14 07:40 UTC (History)
9 users (show)

Fixed In Version: 5.5.5.2
Doc Type: Bug Fix
Doc Text:
Previously, running SmartState Analysis on VMware virtual machine volumes produced an empty report. This was caused by the Hardware.Volumes attribute (such as free space, free space %, used space) data not populating, because the 'checkall' expression was used to create the report instead of 'checkany'. With this update, the yaml code has been changed to use 'checkany' in the FIND expression, and volume information is reported correctly.
Clone Of: 1319764
Environment:
Last Closed: 2016-07-26 15:31:54 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Comment 4 Satyajit Bulage 2016-07-25 13:52:04 UTC
Able to generate Reports for "VMs with Volume Free Space <= 20%" with all the data populated properly.

Verified version :-5.5.5.4.20160722162813_629f93b

Comment 6 errata-xmlrpc 2016-07-26 15:31:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html


Note You need to log in before you can comment on or make changes to this bug.