Bug 13217 - Kickstart install fails when attempting to install mouse
Kickstart install fails when attempting to install mouse
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-29 12:34 EDT by mjrmoron
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-08 16:03:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mjrmoron 2000-06-29 12:34:13 EDT
The kickstart install fails when attempting to install mouse.  I have tried 
using a generic two button mouse instead of a Microsoft mouse, but the 
install program continually fails when attempting to install the Microsoft 
mouse with the emulthree option.

I have used the latest patch for the boot disk from the Redhat site along 
with the update disk.  I am now able to install GNOME workstation using the 
gui, but am unable to install using kickstart.
Comment 1 Michael Fulbright 2000-06-30 16:14:22 EDT
Test lab - please verify if this is realted to an earlier 6.2 bug report
about kickstart/mouse detection please.
Comment 2 mjrmoron 2000-07-05 09:04:01 EDT
Yes. This is related to the earlier 6.2 bug report about kickstart/mouse 
detection. I am using the disk images provided by Redhat (Bug ID 
RHBA-2000:015-01).  The kickstart file being used is:
### 

###    Language
lang en

### Netowrk protocol
network --bootproto static --ip 100.100.0.2 --netmask 255.255.255.0 --gateway 
100.100.0.25 --nameserver 100.100.0.10

### The installation source
cdrom

### Use Intel 10/100 EtherExpress ethernet Card
device ethernet eepro100

### Keyboard definition
keyboard us
        
### Re-write the master boot record
zerombr yes
        
### Repartition the hard drive
clearpart --all
        
### Create swap partition -- this will go on a logical  partition
part swap --size 200

### Root partition - 500M 
part / --size 500 

### INTV AND APPL directory 
part /usr --size 3000 --grow

### Use MicroSoft compatible mouse  
mouse --kickstart microsoft --device ttyS1
       
### Install or Upgrade      
install 

### Select timezone
timezone --utc US/Central

### Use standard VGA 16
xconfig --server XF86_VGA16

#### Root password 
rootpw INTVPASS

#### Use shadow passwording
auth --useshadow
        
### Install Lilo at the master boot record
lilo --location mbr

### Packages
%packages
@ Base
@ X Window System
@ Gnome Workstation
@ Web Server
@ Networked Workstation
Comment 3 Michael Fulbright 2000-07-13 14:53:34 EDT
If you leave the '--kickstart' off of the mouse config line in your kickstart
file does it work?
Comment 4 mjrmoron 2000-07-18 11:18:30 EDT
When I removed the --kickstart off the mouse line from the ks.cfg, then I got the following error:
Traceback (innermost last):
File "/usr/bin/anaconda", line 45, in ?
  ['gui', 'text', 'reconfig', 'test', debug'
File "/usr/lib/anaconda/isys.py", line 198, in getopt return apply(_isys.getopt, args)
Type error: bad argument --kickstart:missing argument.

When I put the --kickstart back in the mouse line in ks.cfg I got the original error again.
Comment 5 Brent Fox 2000-08-09 12:11:13 EDT
Try replacing the line for the mouse in the kickstart file with "mouse
generic3ps/2" and see if that works.
Also, you might try just "mouse".  It should probe the mouse to find out what
type it is.
Comment 6 Brock Organ 2000-08-16 17:14:37 EDT
hmmm ... I am unable to reproduce your traceback ... :( 

I used a ks file based on your above file, with the --kickstart option removed
from the mouse config line:

lang en_US
network --bootproto dhcp
cdrom
device ethernet eepro100
keyboard us
zerombr yes
clearpart --all
part swap --size 200
part / --size 500
part /usr --size 3000 --grow
#mouse --kickstart microsoft --device ttyS1
mouse microsoft --device ttyS1
install
timezone --utc US/Central
xconfig --server XF86_VGA16
rootpw foobarbazandbooie
auth --useshadow
lilo --location mbr
%packages
@ Base
@ X Window System

This install completes properly, and X is properly configured wrt to the mouse
post-install ... does my slightly stripped down version work for you ...?

Note You need to log in before you can comment on or make changes to this bug.