Bug 1321710 - Can't modify frozen Hash error when trying to reregister a content-host after subscription-manager clean
Summary: Can't modify frozen Hash error when trying to reregister a content-host after...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: rhci-common-installer
TreeView+ depends on / blocked
 
Reported: 2016-03-29 01:48 UTC by Justin Sherrill
Modified: 2019-09-26 17:34 UTC (History)
6 users (show)

Fixed In Version: rubygem-katello-3.0.0.17-1,gofer-2.7.6-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:29:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 14354 None None None 2016-04-22 16:04:17 UTC

Description Justin Sherrill 2016-03-29 01:48:46 UTC
To reproduce:

1. Register a content host.

2. Run subscription-manager clean on the content host.

3. Then try to register the content host again.

The error that will come back in the command like will be: https://paste.fedoraproject.org/344740/88402101/

Expected Results:

It reregisters the content-host.

Comment 1 Justin Sherrill 2016-03-29 01:48:48 UTC
Created from redmine issue http://projects.theforeman.org/issues/14354

Comment 3 Jason Montleon 2016-03-29 15:17:14 UTC
I see this even when trying to register hosts for the first time. The fix above seems to fix it as well.

Comment 4 Mike McCune 2016-04-14 05:00:42 UTC
resolved via:

https://github.com/Katello/katello/pull/5831

Comment 5 Sachin Ghai 2016-04-18 10:03:32 UTC
verified with sat6.2 beta snap8.2

Reported issue has been fixed.

~]# subscription-manager register --activationkey ak_rhel7 --org Default_Organization
The system has been registered with ID: 95e16a1a-db36-4658-bed5-0d98c2ccf899 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Not Subscribed

Unable to find available subscriptions for all your installed products.


 ~]# subscription-manager clean
All local data removed


 ~]# subscription-manager register --activationkey ak_rhel7 --org Default_Organization
The system has been registered with ID: 59c1cc69-2273-4a8b-bb8c-81ad50fea3d2 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Not Subscribed


I don't see any stacktrace while running any of these commands.

Comment 7 errata-xmlrpc 2016-07-27 09:29:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.