Bug 1321774 - [virtio-win][vioscsi]fio jobs keep printing "0% done" in win2012r2 guest
Summary: [virtio-win][vioscsi]fio jobs keep printing "0% done" in win2012r2 guest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-29 06:32 UTC by Yumei Huang
Modified: 2016-11-04 08:53 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:53:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
The screenshot of actual results. (52.47 KB, image/png)
2016-03-29 06:32 UTC, Yumei Huang
no flags Details
The screenshot of result with virtio-win-whql-0.1-108 (47.36 KB, image/png)
2016-03-29 06:34 UTC, Yumei Huang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Yumei Huang 2016-03-29 06:32:07 UTC
Created attachment 1141102 [details]
The screenshot of actual results.

Description of problem:
When run fio cmd in win2012r2 guest with virtio-scsi mutiqueue, fio jobs keep printing  "0% done".

Version-Release number of selected component (if applicable):
kernel-3.10.0-327.15.1.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.10
virtio-win-prewhql-0.1-116
fio-2.2.10-x64

How reproducible:
always

Steps to Reproduce:
1. boot 2012r2 guest with virtio-scsi mutiqueue:
/usr/libexec/qemu-kvm -S -name 'virt-tests-vm1' -nodefaults \

 -chardev socket,id=hmp_id_humanmonitor1,path=/tmp/monitor-humanmonitor1-20160328-020400-ZsvxrFcS,server,nowait -mon chardev=hmp_id_humanmonitor1,mode=readline    \

 -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20160328-020400-ZsvxrFcS,server,nowait -device isa-serial,chardev=serial_id_serial1  \ 

-chardev socket,id=seabioslog_id_20160328-020400-ZsvxrFcS,path=/tmp/seabios-20160328-020400-ZsvxrFcS,server,nowait  -device isa-debugcon,chardev=seabioslog_id_20160328-020400-ZsvxrFcS,iobase=0x402  \

-device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x3 \

-drive file='/usr/local/autotest/tests/virt/shared/data/images/win2012r2-64.raw',if=none,id=drive-ide0-0-0,media=disk,cache=none,snapshot=off,format=raw,aio=native -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0     \

-device virtio-scsi-pci,id=virtio_scsi_pci0,addr=0x4,num_queues=1  \

-drive file='/dev/ram0',if=none,id=virtio-scsi-id0,media=disk,cache=none,snapshot=off,format=raw,aio=native -device scsi-hd,drive=virtio-scsi-id0     \

-drive file='/dev/ram1',if=none,id=virtio-scsi-id1,media=disk,cache=none,snapshot=off,format=raw,aio=native -device scsi-hd,drive=virtio-scsi-id1     \

-drive file='/dev/ram2',if=none,id=virtio-scsi-id2,media=disk,cache=none,snapshot=off,format=raw,aio=native -device scsi-hd,drive=virtio-scsi-id2     \

-drive file='/dev/ram3',if=none,id=virtio-scsi-id3,media=disk,cache=none,snapshot=off,format=raw,aio=native -device scsi-hd,drive=virtio-scsi-id3     \

-device virtio-net-pci,netdev=idIM5MXK,mac='9a:37:37:37:37:5e',bus=pci.0,addr=0x5,id='id8MZfhI' -netdev tap,id=idIM5MXK     \

-m 4096 -smp 2,cores=1,threads=1,sockets=2  -cpu 'SandyBridge' -M pc     \

-drive file='/usr/local/autotest/tests/virt/shared/data/isos/windows/winutils.iso',if=none,id=drive-ide0-0-1,media=cdrom,format=raw  -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1    \

-device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1     \

-vnc :0 -vga cirrus -rtc base=localtime,clock=host,driftfix=slew  -boot order=cdn,once=c,menu=off   -device sga  -enable-kvm -monitor stdio

2. online and initialize four disks in disk management.

3. run fio in cmd:
fio.exe --rw=read --bs=4k --iodepth=1 --runtime=1m --direct=1 --ioengine=windowsaio --thread --group_reporting --numjobs=16 --time_based --name=job1 --filename=\\.\PHYSICALDRIVE1 --name=job2 --filename=\\.\PHYSICALDRIVE2 --name=job3 --filename=\\.\PHYSICALDRIVE3 --name=job4 --filename=\\.\PHYSICALDRIVE4 --output=C:\\fio_result


Actual results:
fio jobs keep printing "0% done" after finishing  "100% done". The screenshot is attached. 

Expected results:
fio jobs finish correctly, just like virtio-win-prewhql-0.1-108. See the attachment "virtio-win-whql-108 Result.png"

Additional info:
Hit same issue on virtio-win-prewhql-0.1-115. 
virtio-win-prewhql-0.1-108 works well.

Comment 1 Yumei Huang 2016-03-29 06:34:10 UTC
Created attachment 1141103 [details]
The screenshot of result with virtio-win-whql-0.1-108

Comment 3 Vadim Rozenfeld 2016-07-04 06:06:18 UTC
Is it still reproducible  with drivers from build 121?
Thanks,
Vadim.

Comment 4 Yumei Huang 2016-07-04 06:10:47 UTC
(In reply to Vadim Rozenfeld from comment #3)
> Is it still reproducible  with drivers from build 121?
> Thanks,
> Vadim.

I will test it when the host is available.

Comment 5 Yumei Huang 2016-07-04 08:39:33 UTC
It is not reproducible with drivers from build 121. Fio jobs work well.

Comment 6 Vadim Rozenfeld 2016-07-04 09:42:22 UTC
(In reply to Yumei Huang from comment #5)
> It is not reproducible with drivers from build 121. Fio jobs work well.

Thanks for your prompt response.

Vadim.

Comment 7 Yu Wang 2016-07-07 04:03:29 UTC
According comment#5, change status to verified

Comment 9 errata-xmlrpc 2016-11-04 08:53:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.