Bug 132186 - Cannot switch from X to console anymore using Ctrl-Alt-F1..F6
Summary: Cannot switch from X to console anymore using Ctrl-Alt-F1..F6
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: rawhide
Hardware: powerpc Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: fedora-ppc
TreeView+ depends on / blocked
 
Reported: 2004-09-09 18:57 UTC by jeroen
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-20 13:04:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jeroen 2004-09-09 18:57:58 UTC
For a while now, i haven't been able to switch to a text console
anymore on my powerbook. This happened some time ago after updating
from the development repository with yum.

Pressing Ctrl-Alt-F1 does nothing anymore on my powerbook (it used to
work fine). Is this an actual bug somewhere specific to ppc? Or has
some init/configuration script changed during yum updating? If so,
where should i look for this?

Comment 1 David Lawrence 2004-09-09 19:01:16 UTC
I have noticed the same thing on my 15 inch titanium. Running latest
rawhide updates.

Comment 2 Colin Charles 2004-09-12 01:42:55 UTC
What are you guys (both dkl and jeroen) having in /etc/X11/xorg.conf
as your keyboard identifiers?

If your:
        Option      "XkbModel" "pc105"

the switching should work. It only breaks when XkbModel is set to
"macintosh" right?

Looks like an upstream xkb issue (and mharris hates xkb :P)

Comment 3 Wade Mealing 2004-09-12 14:51:50 UTC
Confirmed, that the problem exists in 0903 nightly install.

Comment 4 Benjamin Herrenschmidt 2004-09-19 06:10:09 UTC
Same issue, I confirm that it breaks with both the "macintosh/us"
keymap that comes with Xorg CVS and with my home hacked "fr" one (see
xorg list, though I can include it if you want).


Comment 5 Kristian Høgsberg 2004-09-19 22:48:32 UTC
I haven't been able to reproduce the bug (I don't have PPC hardware),
but here's a thing to try out: Add this line to
/usr/X11R6/lib/X11/xkb/symbols/macintosh/us at line 150 (after the
other include statements):

  include "srvr_ctrl(xfree86)"

That may or may not fix it, please let me now.


Comment 6 David Woodhouse 2005-02-19 03:27:03 UTC
This is working for me in rawhide, and was working in FC3. Is anyone
else still suffering?


Note You need to log in before you can comment on or make changes to this bug.