Bug 13219 - RFE: Selecting keyboard layout based on installer language
Summary: RFE: Selecting keyboard layout based on installer language
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-29 17:53 UTC by Christian Rose
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-02 04:21:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Rose 2000-06-29 17:53:38 UTC
Wouldn't it be nice if the default selected keyboard layout in the Keyboard
selection box was chosen based upon what installation language I selected
in the screen before? Right now, even if I'm using the installer
in Swedish, it defaults to "us" keyboard layout, although there is probably
a very large chance that I as an user
would want "se-latin1" in most cases, given my selection of language.

I think that making an intelligent choice in the keyboard configuration
based on what language the user previously chose and selecting that
keyboard layout as default would probably be a nice addition. (Note that
I'm not advocating entirely skipping the keyboard selection step, merely
making a better layout-selection default in the list box, based on
language, intstead of always "us".)

Comment 1 Christian Rose 2000-07-13 21:27:29 UTC
Also, if this feature is added, make sure that the scroll box is adjusted so
that the selection is in the visible part!

Comment 2 Christian Rose 2000-08-01 22:34:43 UTC
This feature isn't added in Pinstripe, so I bumped the beta number.

Comment 3 Matt Wilson 2000-08-02 04:21:01 UTC
This feature has been in since beta1, but the mapping currently defaults to
"us".  I will change it to se-latin1


Comment 4 Christian Rose 2000-08-14 12:54:31 UTC
Nice, I noticed that it worked now in RC1. Thanks!
Closing this.


Note You need to log in before you can comment on or make changes to this bug.