Bug 1321919 - Atomic host upgrade fails with error: Server returned status 404: Not Found
Summary: Atomic host upgrade fails with error: Server returned status 404: Not Found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Partha Aji
QA Contact: Sachin Ghai
URL:
Whiteboard:
Depends On:
Blocks: 1321771
TreeView+ depends on / blocked
 
Reported: 2016-03-29 11:34 UTC by Sachin Ghai
Modified: 2019-09-26 17:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:29:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
avc denials on registering the host with server, related to rhsmcertd-worke (22.22 KB, image/png)
2016-03-29 11:34 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Sachin Ghai 2016-03-29 11:34:29 UTC
Created attachment 1141207 [details]
avc denials on registering the host with server, related to rhsmcertd-worke

Description of problem:
I provisioned atomic host via satellite6.2 and registered it using subscription-manager using "Katello Atomic kicstart default' template. Host is registered with server.

I can see correct redhat.conf file.

-bash-4.2# cat /etc/ostree/remotes.d/redhat.conf 
[remote "rhel-atomic-host-ostree"]
url = https://cloud-qe-3.idmqe.lab.eng.bos.redhat.com/pulp/repos/Default_Organization/Dev/cv_ostree/content/dist/rhel/atomic/7/7Server/x86_64/ostree/repo
gpg-verify = false
tls-client-cert-path = /etc/pki/entitlement/1267190861025925549.pem
tls-client-key-path = /etc/pki/entitlement/1267190861025925549-key.pem
tls-ca-path = /etc/rhsm/ca/katello-server-ca.pem


but when I ran atomic host upgrade, got following:

-bash-4.2# atomic host status
  TIMESTAMP (UTC)         VERSION     ID             OSNAME               REFSPEC                                                        
* 2016-02-18 15:34:28     7.2.2-1     04019d7e50     rhel-atomic-host     rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard   
  
-bash-4.2# atomic host upgrade
Updating from: rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
error: Server returned status 404: Not Found


Version-Release number of selected component (if applicable):
Satellite 6.2 snap5.1

How reproducible:
always


Steps to Reproduce:
1. provision atomic host via satellite server
2. registered it with server via subscription-manager
3. atomic host upgrade

Actual results:
-bash-4.2# atomic host upgrade
Updating from: rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
error: Server returned status 404: Not Found


Expected results:
host should be upgraded.

Additional info:
I can see some avc denials on registering the host with server, related to rhsmcertd-worke. Please see the screenshot

I don't find audit.log on atomic host. So attaching logs from console.

Comment 2 Partha Aji 2016-03-30 16:31:16 UTC
The rhsm.conf is not pointing to the right location . Should be fixed by -> https://bugzilla.redhat.com/show_bug.cgi?id=131806

Comment 3 Sachin Ghai 2016-03-31 11:55:43 UTC
Verified with sat6.2 beta snap6.


I successfully provisioned atomic host via Satellite server and it auto get registered with server using "Katello Atomic Kickstart default' template and associated activation-key.

Comment 5 Sachin Ghai 2016-03-31 11:58:43 UTC
Atomic host is upgraded successfully.

-bash-4.2# atomic host upgrade
Updating from: rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard

27 metadata, 58 content objects fetched; 95479 KiB transferred in 7 seconds
Copying /etc changes: 21 modified, 4 removed, 44 added
Transaction complete; bootconfig swap: yes deployment count change: 1
Changed:
  ceph-common 1:0.94.3-6.el7cp -> 1:0.94.5-9.el7cp
  librados2 1:0.94.3-6.el7cp -> 1:0.94.5-9.el7cp
  librbd1 1:0.94.3-6.el7cp -> 1:0.94.5-9.el7cp
  openssl 1:1.0.1e-51.el7_2.2 -> 1:1.0.1e-51.el7_2.4
  openssl-libs 1:1.0.1e-51.el7_2.2 -> 1:1.0.1e-51.el7_2.4
  python-rados 1:0.94.3-6.el7cp -> 1:0.94.5-9.el7cp
  python-rbd 1:0.94.3-6.el7cp -> 1:0.94.5-9.el7cp
Run "systemctl reboot" to start a reboot
-bash-4.2# 



After upgrade, I can see the updated version 7.2.2-2

-bash-4.2# atomic host status
  TIMESTAMP (UTC)         VERSION     ID             OSNAME               REFSPEC                                                        
  2016-03-01 01:35:21     7.2.2-2     8b2cf24b42     rhel-atomic-host     rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard     
* 2016-02-18 15:34:28     7.2.2-1     04019d7e50     rhel-atomic-host     rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard

Comment 7 errata-xmlrpc 2016-07-27 09:29:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.