Bug 132194 - scanner visable but unusable
scanner visable but unusable
Status: CLOSED DUPLICATE of bug 121511
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-09 15:15 EDT by Dan Christian
Modified: 2014-03-16 22:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Christian 2004-09-09 15:15:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
I plug in a scanner that used to work under FC1 (Epson Perfection 2450
Photo).  This scanner has been supported by sane for some time.

lsusb and sane-find-scanner see the device, but it never gets
associated with /dev/usb/scanner0.

xsane or "scanimage -L" try to open the right devices but gets ENODEV
on all possible entries.

Running as root doesn't change anything.

It doesn't matter if the scanner is hooked up a boot or not.

Version-Release number of selected component (if applicable):
xsane 0.92 and 0.96 act identically.  
"scanimage -L" also fails to connect to the scanner.

I get similar results using firewire.  This never worked quite right
under firewire with sane, but it used to connect OK.

How reproducible:
Always

Steps to Reproduce:
1.Plug in Epson 2450 to USB
2.lsusb
3.sane-find-scanner
4.xsane
    

Actual Results:  xsane can't find the scanner.
Running "strace -e trace=open xsane 2>&1 | grep /dev" shows that all
possible devices return ENODEV.

Expected Results:  Scanner should show up

Additional info:
lsusb shows this: 
Bus 001 Device 009: ID 04b8:0112 Seiko Epson Corp. Perfection 2450

sane-find-scanner shows this:
found USB scanner (vendor=0x04b8 [EPSON], product=0x0112 [EPSON
Scanner]) at libusb:001:009

This system was upgraded from FC1 to FC2.
Comment 1 Dan Christian 2004-09-09 19:19:26 EDT
Some more info.  I turned on some debugging.

Sep  9 16:19:03 maccready kernel: usb 1-3: new high speed USB device
using address 4
Sep  9 16:19:04 maccready usb.agent[3523]: Setup 0x00 0x00
libusbscanner for USB product 4b8/112/101
Sep  9 16:19:04 maccready usb.agent[3523]: Module setup libusbscanner
for USB product 4b8/112/101
Sep  9 16:19:04 maccready logger: libusbscanner add /proc/bus/usb/001/004

I added the last message to /etc/hotplug/usb/libusbscanner.  I'm a bit
supprised that the device it is setting permissions on is under /proc,
not /dev.  Is this right?
Comment 2 Bill Nottingham 2005-02-04 16:11:04 EST

*** This bug has been marked as a duplicate of 121511 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.