Bug 1322036 - Text in disk selector widget on INSTALLATION DESTINATION screen no longer styled
Summary: Text in disk selector widget on INSTALLATION DESTINATION screen no longer styled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-29 15:27 UTC by Adam Williamson
Modified: 2016-04-06 14:06 UTC (History)
6 users (show)

Fixed In Version: anaconda-24.13.3-1 anaconda-24.13.3-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-06 14:06:25 UTC


Attachments (Terms of Use)
how the screen used to look (I believe this is 'correct' / 'as intended') (74.36 KB, image/png)
2016-03-29 15:31 UTC, Adam Williamson
no flags Details
how the screen looks now (I believe this is a bug) (42.00 KB, image/png)
2016-03-29 15:31 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2016-03-29 15:27:59 UTC
In recent Rawhide composes, openQA tests that need to select target disks are failing because the disk selection widget on INSTALLATION DESTINATION does not look quite as expected. Until recently the text in the widget had some kind of styling applied to it; now it seems to be some kind of default rendering. In F24 images and earlier Rawhide images, the disk identifer text (which is an incomprehensible hex string for virtIO disks, these days) was in bold face; now it is not. The other text in the box used the same font size as the instruction text above it; now it is rather smaller.

I'm attaching two screenshots for comparison. The one where the header image is visible is how it looked before (the screenshot was taken from Rawhide shortly before F24 branched); F24 still looks more or less like that (for now, anyway, maybe when the new GTK+ build for F24 goes stable it'll have the same issue as Rawhide). The one where there's no header image is how it looks right now.

Comment 1 Adam Williamson 2016-03-29 15:31:01 UTC
Created attachment 1141321 [details]
how the screen used to look (I believe this is 'correct' / 'as intended')

Comment 2 Adam Williamson 2016-03-29 15:31:24 UTC
Created attachment 1141322 [details]
how the screen looks now (I believe this is a bug)

Comment 3 Adam Williamson 2016-03-29 18:07:15 UTC
We also use this particular spot in anaconda to test updates.img in openQA, by replacing the 'disk is selected as a target' checkmark emblem with another image. This is also not working ATM. I'm not 100% sure if it's a consequence of this bug or if it really indicates the updates.img is not being loaded. The change in the updates image is, AFAICT, to replace /usr/share/anaconda/pixmaps/anaconda-selected-icon.svg .

Comment 4 David Shea 2016-03-30 20:31:03 UTC
This appears to be an issue with gtk. Addressing the most obvious missing thing, the topbar background: anaconda-gtk.css includes the following rule

AnacondaSpokeWindow #nav-box {
    background-color: @fedora;
    background-image: url('/usr/share/anaconda/pixmaps/topbar-bg.png');
    background-repeat: repeat;
    color: white;
}

fiddling around with the inspector, the "AnacondaSpokeWindow #nav-box" selector no longer works, but just "#nav-box" does.

The problems with the text are probably the same issue, since AnacondaDiskOverview uses similar CSS selectors to apply the text styles.

Comment 5 Matthias Clasen 2016-03-30 20:42:24 UTC
Selecting by type names in css is not supported anymore. You can either set your own css names with gtk_widget_class_set_css_name or use style classes.

Comment 6 Fedora Update System 2016-04-04 21:25:27 UTC
anaconda-24.13.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd26edfec7

Comment 7 Fedora Update System 2016-04-05 19:22:03 UTC
anaconda-24.13.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd26edfec7

Comment 8 Fedora Update System 2016-04-06 14:06:05 UTC
anaconda-24.13.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.